Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Star Trek Online General Discussion (http://sto-forum.perfectworld.com/forumdisplay.php?f=128)
-   -   MK VII items showing the stats of MK I items (http://sto-forum.perfectworld.com/showthread.php?t=101911)

Archived Post 02-04-2010 03:46 AM

MK VII items showing the stats of MK I items
 
I noticed yesterday that almost all of my items (MK V-VII) show very low stats on them.
For example:
My MK VII shields have something around 1688 hp and a regen rate of around 60. When mounted I shows 3700 hp in the char stat window but my shields still go down after one high yield III by a NPC battle ship dealing around 3-4x 300-400 damage. And this is not a simple "oh Im getting owned there must be something wrong on the other side of the screen". Just want to know where the problem lies if there is one. Might just my imagination giving me a run for my money. And it might be interesting to know that the items show normal values to other people when I post them into the chat.

On another note Id like to know if it is normal that my phaser dual cannons MK VII only deal around 50-60 damage on enemy shields using rapid fire III attack pattern alpha III, beta II and fire on my mark (I presume that the resist debuff only applies on hull damage). But 50-60 barely scratches enemy shields even with rapid fire III. This is especially curious when I see that Im getting hit by disruptor and phaser arrays for the same amount of damage (50-60).

Archived Post 02-04-2010 04:29 AM

1.

You're an escort. Shield stats switch accordingly to ship and class.

2.

Are you firing from above 5km? Are you draining/using too little weapon power? What are you firing at, and what buffs do they have?

Archived Post 02-04-2010 04:33 AM

Quote:

Originally Posted by -Jes-
1.

You're an escort. Shield stats switch accordingly to ship and class.

2.

Are you firing from above 5km? Are you draining/using too little weapon power? What are you firing at, and what buffs do they have?


weapon power set at 100 and is effective at 105. And I have 3x phaser mods +20 (yes I know that the third one is probably obsolete due ti diminishing return effects)

when I fire at <5km the damage gets closer to the beam array damage I usually receive.


All times are GMT -7. The time now is 12:45 PM.