Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Federation Gameplay (http://sto-forum.perfectworld.com/forumdisplay.php?f=165)
-   -   Night of the Comet (http://sto-forum.perfectworld.com/showthread.php?t=1051021)

renata666 03-13-2014 02:20 PM

Night of the Comet
 
Ok, how the hell do you get past that stupid slingshot deal? I quit counting how many times I've tried, and I just can't do it. Can't seem to turn quick enough to make the 3rd gate.

Anyone know how???

capnmanx 03-13-2014 02:33 PM

I'm afraid there isn't really any trick to it; it's not supposed to be particularly challenging.

Do you have a particularly slow turning ship? If so, try getting some RCS consoles or something.

Also, try using the keyboard controls for turning if you don't already (it always worked for me).

grylak 03-13-2014 02:36 PM

If you fail about 3 times in a row (don't leave the mission between each try), you should get an option saying your computer has calculated the course trajectory needed from the failures and you can engage autopilot, thus allowing you to 'skip' the manual slingshot and carry on.

krrja 03-13-2014 02:47 PM

Most of the problem I had previously with this mission was related to camera positioning. Try zooming in a bit and locking the camera so that it follows your ship as you turn.

neomodious 03-13-2014 03:26 PM

Some ships just don't have the turn rate needed to make that slingshot. I first tried that mission on a klingon in a vo'quv... didn't work very well...

kadams 03-13-2014 05:59 PM

Abuse Evasive Maneuvers? Buy a bunch of RCS consoles? Put more power to engines?

theshrouded 03-13-2014 07:05 PM

use both mouse buttons its more precise then the keyboard

bendalek 03-14-2014 12:15 AM

Your FO should offer to let the computer do it for you after a couple of failures ...

I've never had a problem. because I always use a combination of the above techniques ... Zoom right up close to your ships tail, and use both mouse buttons ...

dakaan750 03-14-2014 01:26 AM

I passed it on first try on my vu'qov yesterday. Always use both mouse buttons to steer. But after 2 failed attempt you should be getting autopilot choice

renata666 03-14-2014 05:55 AM

Ok. I guess I was giving up too soon. I'll try it again, and look for the auto pilot option if I fail 3 times.

Thanks for all the replies.


All times are GMT -7. The time now is 02:55 AM.