Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Star Trek Online General Discussion (http://sto-forum.perfectworld.com/forumdisplay.php?f=128)
-   -   Nvidia can suck a fat one (http://sto-forum.perfectworld.com/showthread.php?t=112179)

Archived Post 02-10-2010 06:16 AM

Nvidia can suck a fat one
 
So, as we all know STO has crashing issues with drivers. I use windows 7 64bit with an nvidia GTS 250. I started getting the same crashing issues in left 4 dead 2, and other various games I never did before playing STO. I tried all sorts of tweaks and workarounds but no luck. So one day I say "#$%^ it" and uninstall anything Nvidia. After the computer reboots, windows installs the last known driver certified and compatible.

This old ass driver here... 8.15.11.8593 from back in 7/13/2009 has not crashed once. Not in STO, or anything else. STO complains every time I start it up that I'm using old drivers, but I ignore it. The game runs great now and Nvidia can kiss my grits. Their drivers suck, and might be hurting STO sales because people don't know why they are crashing. It's the drivers... plain and simple.

Archived Post 02-10-2010 06:21 AM

I feel your pain... but i have to say, i got also win7 64b, and GTS 250, i use the drivers from november `09, never had problems. And yes, Nvidia drivers suck :-)

Archived Post 02-10-2010 06:21 AM

You seem to have bad luck...i have Nvidia 295 Quad Sli in my rig with newest drivers and had no problems thus far

Archived Post 02-10-2010 06:25 AM

Quote:

Originally Posted by Lx31
So, as we all know STO has crashing issues with drivers. I use windows 7 64bit with an nvidia GTS 250. I started getting the same crashing issues in left 4 dead 2, and other various games I never did before playing STO. I tried all sorts of tweaks and workarounds but no luck. So one day I say "#$%^ it" and uninstall anything Nvidia. After the computer reboots, windows installs the last known driver certified and compatible.

This old ass driver here... 8.15.11.8593 from back in 7/13/2009 has not crashed once. Not in STO, or anything else. STO complains every time I start it up that I'm using old drivers, but I ignore it. The game runs great now and Nvidia can kiss my grits. Their drivers suck, and might be hurting STO sales because people don't know why they are crashing. It's the drivers... plain and simple.

I have a GTS 250 and never crash and haven't had any problems since launch. I'm also using Windows 7 64bit HP.

So the chances are the problem is something do with your computer.

Archived Post 02-10-2010 06:42 AM

GTX 280, fresh Win7 64 install on latest Nvidia drivers. Smooth as silk. Only crash I've had lately was due to trading a bugged Mudd Trader in sector space.

Archived Post 02-10-2010 06:45 AM

sounds like a temperature problem to me, check your temps. sto is known for HEAVY gfx and cpu load.

Archived Post 02-10-2010 06:49 AM

Quote:

Originally Posted by zerosoul (Post 2025879)
sounds like a temperature problem to me, check your temps. sto is known for HEAVY gfx and cpu load.

To add to this suggestion, double-check that the fan on your card is turning freely. I've seen what you said OP happen with a card which fan has stopped moving properly... it moved but not as fast as it should. And usually it happened when I bought PNY cards more than other manufacturers for some reason.

Archived Post 02-10-2010 06:50 AM

you also may type in /maxfps 60 or less to see if it helps.

Archived Post 02-10-2010 07:10 AM

Win 7 64 bit
gts 250
latest nvidia drivers.

Only one crash in open beta, and not a single one since it went live.

Archived Post 02-10-2010 07:11 AM

I'm running a Nvid8600gt with old drivers and I have no problems through CB/OB and now live.


All times are GMT -7. The time now is 02:02 AM.