Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Antiproton Weapons are counting as phaser damage. (http://sto-forum.perfectworld.com/showthread.php?t=114711)

Archived Post 02-12-2010 08:34 AM

Dual Antiproton Beam Bank: Phaser Damage Type
 
I just got my first Antiproton Beam Bank this morning, and I was a bit surprised at what I saw. "809 Phaser Damage"

So thinking it was just a typo, I just put on thee Antiproton mags and checked the listed DPS on the weapon bar. "809 Phaser Damage" So.. Being very weary now, I transwarped to Sol and bought a MK IV phaser relay.

Sure enough, "858 Phaser Damage".

I would be a lot less concerned about this if I had skilled into phasers, but I'm a disruptor tard, so I can't really exploit this bug.

I have already filed the bug report about it, but given the fact that I have bug reports from Head Start that have not even been acknowledged.... I decided to post about it. Forum threads seem to get noticed a lot sooner then ticket number 653029.

Combat Log and Tooltip
Tooptip after +15 Phaser Console

Edit: Added in screenshot. Because as we all know, pics or it didn't happen.
Edit: Put in actual ticket ID for accurate referencing.

Edit: Upon further investigation of the other AP weapons, it appears that the bug is running purely with the Dual AP Beam Banks, which also have a bugged item icon. However, this is still a somewhat serious issue.

Kinda surprised that this got through the internal testing, if there was any.

Archived Post 02-12-2010 08:43 AM

Tooltips are often incorrect/misleading in STO currently (unfortunately). Text problem =/= bug.

Got shoot something with the antiproton weapons and check the combat log. It'll say the actual damage type there, rather than what the tooltip thinks the damage is. If it's actually doing phaser damage, then you get to call it a bug. If it is in fact dong antiproton damage, then you do not. Also, I think abilities and items that affect weapon damage affect output if the weapon type is that (ie. with a +10 tetryon console, you do +10 if a tetryon named weapon is equipped, rather than +10 if you're doing tetryon damage.) I could be wrong, though.

Archived Post 02-12-2010 08:52 AM

Combat log and item tooltip.

It's a bug.

Archived Post 02-12-2010 03:06 PM

Double post, and bumping in a single reply. I'm on a roll. :D Bringing to front for attention.

Archived Post 02-12-2010 05:15 PM

Quote:

Originally Posted by BlackWyvern (Post 2056729)

It seems to have been fixed!

Archived Post 02-12-2010 06:36 PM

Still Broken. Dual Anti-Proton Beam Banks do Phaser dmg ( and are total **** compared to mark X green Plasmas.. wtf)

Archived Post 02-12-2010 07:44 PM

I'll be picking up the first of two dual cannons tomorrow, so I'll be able to see if that bug is crossing over to all of them, or just the beam banks for now. Hopefully it's just a single-item bug, given its icon is also boned.

Archived Post 02-13-2010 03:48 AM

Crappy if you expect the correct damage type but should be good for use phaser spec people until it's fixed.

I'll check out my rifle damage type.

Archived Post 02-13-2010 06:17 PM

Just purchased the first of my AP dual cannons. Damage is appearing as AP and is being affected by AP consoles.

Bug seems to be localized to the dual banks. I will update the title accordingly.

Archived Post 02-14-2010 07:06 AM

Beam
Up
My
Post

Returning to top for attention.


All times are GMT -7. The time now is 08:54 AM.