Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   The Comprehensive Graphical Bugs with Starships Thread (http://sto-forum.perfectworld.com/showthread.php?t=126257)

Archived Post 02-24-2010 09:08 AM

The Comprehensive Graphical Bugs with Starships Thread
 
As I've played through the ranks and commanded different starships, there are a number of things I've noticed that appear to be wrong with the models, textures, etc., that I think should be documented. If you have encountered ones that I haven't mentioned, please document them in a reply and I will add them to the OP.

I will add more classes of starships as time goes on. But for now, I'm going to start with my own ship, the Oracle-class Deep Space Science Vessel.

Oracle Class
  1. No Running Lights
    There are no running lights visible on any part of the Oracle class starship. This is dangerous! Every starship needs at least one set of running lights (green for starboard, red for port). Preferably more. I tend to believe this is a modeling oversight since you see them on every other class of starship, including the other Deep Space Science Vessels.
  2. No Registry Light?
    [image]
    As seen in the image, Cryptic seems to want us to believe that there is a spotlight coming down over the bow to illuminate the name and registry number of the ship, as is common in other starships. But, as Jean-Luc Picard might say, THERE IS NO LIGHT! The spotlight is there, but the light itself is not. This seems to be an unintentional omission.
  3. Sensor Array or Warp Nacelle?
    [image]
    The structure on the bottom of the deep-space science ships is listed as a "secondary array", apparently a sensor array, which makes sense and looks lovely. But on the Oracle class, it is given the long, horizontal blue stripe of a warp nacelle housing. So make up your minds, guys: is it a sensor array or a warp nacelle?
  4. Compatibility with Destiny Hull
    In this image [1], you see a healthy Oracle-class hull. The shuttle bay is clearly visible, neatly tucked up under the impulse engines, perched above the secondary array. But, when used with the Destiny-class hull, disaster strikes! A piece of architecture [2]is suddenly rammed right through the shuttle bay, rendering it inoperable. We're trapped, sir! It's a shame, because I love the Destiny hull, but who wants a ship without a shuttle bay?

More to come when I have time. There are bigger problems with some of the other classes, but I wanted to start with mine.


All times are GMT -7. The time now is 11:36 AM.