Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   New patch broke Ground Zero Mission (http://sto-forum.perfectworld.com/showthread.php?t=128606)

Archived Post 02-26-2010 07:52 PM

New patch broke Ground Zero Mission
 
So I did the Ground Zero Mission this morning, and after I destroyed the final boss in space, I got the old depart sector report and click it to warp out. Only problem is, when I got out and tried to turn in the mission, well it did not say completed. SO I figured I just made a mistake and I would try it again tonight. So here I am back... again.... 2 hrs a piece it takes to do this mission. I ran it again tonight,making sure it said mission completed, and depart sector. Lo and behold, when I zoned out, it stated the mission was not completed. NICE BROKEN STORY MISSION CRYPTIC. Thanks. I am sure you will be patch your patch, just like you have the last 2 patches that have been released. I am sure it will be fixed... but most likely I will need to wait til next week. Oh well, one week lost in the game will not kill me. See you all when this is fixed.

Archived Post 03-05-2010 10:49 PM

Same...
 
Same damn thing happened to me!!!! Of course I did it twice now, and both times the quest would not complete. WTF CRYPTIC! YOU SUCK AND YOU OWE ME 3 HOURS OF MY LIFE BACK!!! It's one thing for a random quest to be bugged, but the 90 minuted episodes NEED TO COMPLETE!! JESUS!


All times are GMT -7. The time now is 01:24 PM.