Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Feature Episodes, Events and PvE Content (http://sto-forum.perfectworld.com/forumdisplay.php?f=122)
-   -   Klingon BO not shooting (http://sto-forum.perfectworld.com/showthread.php?t=130022)

Archived Post 02-28-2010 03:52 PM

Klingon BO not shooting
 
I recently got a Klingon bridge officer (engineering). I bought a bat'leth for him and took him into combat. I noticed he wasn't walking around with it out. Then we got in combat and I noticed he wasn't fighting with it. He was just deploying some turrets and doing some other abilities, then standing around doing nothing.

I thought maybe the bat'leth was the problem, so I gave him a disruptor weapon. I see him carry it around, but still, he doesn't fight with it. I never see him shoot it. He deploys turrets and does his other things, then stands around, not shooting.

What's going on?

Archived Post 02-28-2010 03:57 PM

Bridge officers don't use melee weapons.
They need a gun.

Archived Post 02-28-2010 04:01 PM

Quote:

Originally Posted by denare (Post 2255205)
Bridge officers don't use melee weapons.
They need a gun.

OK...so what about my second paragraph, then?

Archived Post 03-01-2010 01:10 AM

He,s a traitor we are at war with the Klingons, you have obviously been infiltrated.

Archived Post 03-01-2010 11:38 AM

Some time last night, I gave him a Dual Pistols, and saw him shoot those. I may have restarted the game at some point before I gave him the Dual Pistols, but I didn't specifically check to see if he was shooting until I changed his weapon again, so I'm not sure if the restart or the weapon change is responsible for him deciding to shoot now. Either makes just as much sense as the other, for different reasons, but either way, it comes down to flakiness (i.e., bugginess) of the game.


All times are GMT -7. The time now is 03:01 AM.