Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Controls, User Interface, and the STO Gateway (http://sto-forum.perfectworld.com/forumdisplay.php?f=126)
-   -   Disappearing mouse pointer and Hot Bar clicks not registering (http://sto-forum.perfectworld.com/showthread.php?t=134035)

Archived Post 03-06-2010 05:15 AM

Disappearing mouse pointer and Hot Bar clicks not registering
 
Im having issues with the hot-keys intermittently not registering clicks...or my mouse pointer disappearing.

Is there something that can be done to deminish this? My frames/sec are high, so its hard to believe its system lag. I use mouse control for ship movement, I've had times when the ship doesnt/stops maneuvering too.

It just feels like the UI just hic-cups periodically. My keyboard presses seem to be more consistent, especially if I hold the button down until action confirmation, but it seems clicks can be missed...especially in rapid succession.

Archived Post 03-06-2010 11:32 AM

Same here.

Mouse will randomly disappear then reappear when it feels like it.

Action buttons won't always click right, even after it shows on the GUI that it had been clicked.
This has resulted in not firing torpedoes but still having a cool down timer begin as if everything went off as planed, certain skill combo chains I've devised not working properly, weapons not firing specials not firing, ability cool downs and everything.

How can the mouse have so much lag? I mean really, I've never played a game before where the mouse needed so much memory power or what ever to work to the point that it would blink out.

Oh and the mouse trails are back too guys. Have fun fixing that.

Archived Post 03-07-2010 01:39 AM

Maybe it's a focus issue
 
Quote:

Originally Posted by cocoa-jin (Post 2314476)
Im having issues with the hot-keys intermittently not registering clicks...or my mouse pointer disappearing.

Is there something that can be done to deminish this? My frames/sec are high, so its hard to believe its system lag. I use mouse control for ship movement, I've had times when the ship doesnt/stops maneuvering too.

It just feels like the UI just hic-cups periodically. My keyboard presses seem to be more consistent, especially if I hold the button down until action confirmation, but it seems clicks can be missed...especially in rapid succession.

I have had problems with the hot-keys not responding to clicks as well.

Also, I noticed that in PvP, in order to see the team displays, I had to click once inside the box where the 'Reports' and '?' are, and then I could click on the 'Reports' button. If I just clicked directly on the button first, I could not get the button to register a click.

This indicates that the box/window is not in 'focus' or being recognized as being able to receive input by the game.

It's like the box/window is a 'background' item, and has to be clicked once to bring it to the 'foreground' and then all of it's items become active. I wonder if that is happening to the hot-key bar?

Archived Post 03-09-2010 03:26 AM

I cant say Ive seen this type of problem in any other game that i can remember...thats easily more than 10yrs of PC/multiplayer gaming...what is the deal here?

Archived Post 03-13-2010 10:21 PM

Same here w/ the disappearing mouse>
 
As soon as the patch is finished and I hit engage, my mouse disappears and I can't even create a character. Anyone have a cure for this? Please. . .Thanks. - Marajade

Archived Post 03-31-2010 04:08 PM

Been having issues with my mouse constantly, kept thinking it was bad batteries, but even after changing them it persists. Mouse just seems to lag behind everything else going on or when it does register, the inputs are sticking. As with other posters, this is causing failure to balance shields, torpedoes to be set for a cooldown without being fired, inability to target enemies, etc. It's getting highly frustrating and this is the only game I've had this issue with. I've tried several different mice I have around the house, corded and wireless, and the problem doesn't change.

Please help.

Archived Post 03-31-2010 05:20 PM

The ingame mouse is awful , please change it! :)


All times are GMT -7. The time now is 02:07 AM.