Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Since last patch... turrets file while cloaked? (http://sto-forum.perfectworld.com/showthread.php?t=135405)

Archived Post 03-08-2010 02:52 PM

Since last patch... turrets file while cloaked?
 
Ok... I had a few odd experiences in PVP that I am not sure if any others have experienced (i know two have, but they dont post on the forums).

Basically, since the last patch, some Klingon turrets seem to fire while cloaked, you can't see the bolt or the target source, but you can hear the sound, see the impact on your shields and see the shield damage. It confused the crap out of me first time it happened, I was looking around for another ship, but there was none within a good 30k of my position and while i was scanning and turning up nothing, the shields were continually being fired on still. I could hear the turret sound and get a general idea of where the cloaked ship was, but i couldnt lock onto it and he was constantly firing his turret.

After he decloaked and i killed him, someone in the zone said they were seeing this happen too, on the other side of the map, end up going over there to join the main battle and out on his own is another fed ship, circling itself taking shield damage from an invisible source that was trying to get behind him.

It happened to me again a few more times during the night, so i just got frustrated and gave up PVPing, but this definitely did not happen before the patch and it's definitely NOT someone at a distance shooting at me, it was point blank and it was invisible except for shield impacts.

Anyone else seen this? Or is this some sort of crazy rare bug that only 3 people have seen?


All times are GMT -7. The time now is 05:51 PM.