Star Trek Online

Star Trek Online (
-   Windows and General: PC, Network, and Other Technical Issues (
-   -   G13 "glitches" (

Archived Post 03-19-2010 12:39 PM

G13 "glitches"
Has anyone got the G13 to work Flawlessly in STO? I notice that from time to time the ctrl+number or Alt+number causes it to just hit the number. Now I did have a work around by just remapping every hotbar button to a single key but this is lame and should not even be needed. I have tried just using the default ability and making a macro. I have added delays in said macros ranging from .050 to .500 between press of Ctrl and number button and in just about every combination you can imagine.

I know some will claim its a logitech issue, and Cryptic might even agree, but since the pad and software works in other games just fine, my troubleshooting skill set says its something to do with the only other thing that is different which would be STO. So until Cryptic or maybe Logitech comes up with a real fix, has anyone found a work around that works every time instead of most of the time?

Archived Post 03-19-2010 01:17 PM

i have a g15 and the same problem. but worked around my by removing the numpad number from the key binds for the 1 -0 and set my g 15 keys to use ctrl +NumpadNumber , alt+numpadNumber keys

Archived Post 03-19-2010 01:19 PM

Ive read reports about this before I set up my G19, so to advoid the headach I just totally skipped using any key combo's in my macro's. I rempapped what I need to single , unused keys and set up the macros from there.

edit: And I also made sure I enter eack key press 3 times in a macro seperated by a small delay. The game still dosent pick up on keystokes as well as it should and using a keyboard macro it seems to make it worse.

Archived Post 03-19-2010 09:55 PM

being forced to remap to a single key is just silly. There is no good reason for this not to work. I noticed lots of problems even just using the keyboard. You are right that this game is not great at picking up keyboard inputs, the UI needs some work for sure.

Archived Post 03-20-2010 10:12 PM

I'm having same issue with my g13, however at some point it was working fine.

First I tried just binding Ctrl + # as key presses, however that caused both Ctrl + # and # to go off so I changed it to a macro (Ctrl down, # down, # up, Ctrl up) as it worked fine, however it started procing both keys to go off recently as well, it's really annoying.

Going to try it with a slight delay (although I'm not sure how to set the delay to a set value and not have to time it myself)

Archived Post 03-21-2010 08:08 AM

i had the same issue with my G15 script to auto redistribute shields (Strg + 2) that it sometimes only hit the skill on "2".

i added a few small delays and now it works fine:

should look something like this:

shorter delays should work too, i only made it 0,075s to make 100% sure it is not to short, will try smaller ones on the go.

with the 0,075s delay i had the problem that often when i hit Spacebar my Torpedos also fired,
had to delete the "STRG + Space" bind for "fire all weapons".
I fire my Torpedos on a mouse button anyway.

Archived Post 03-28-2010 08:18 PM

Logitech says it's something strange about the timing in STO. :( Hey STO developers, will this get fixed anytime soon?

Archived Post 05-05-2010 10:36 AM

Sorry for the quasi-necro but I picked up a g13 this wekend and had a heck of a time getting anything to work. This thread was the final clue to making a macro work the way I wanted. Before, the macro would fire off as desired but then there would be a several second lag where the whole game would freeze. Thanks to this thread problem solved.

Some details, I was wanting to automagically redistribute shield power by only pushing one button, like on my n52. By default the keypress for that is the "default" key. I created the macro, named it Dist Shields, and turned on Record Delays Between Events. I then hit and released the mapped key three times and stopped recording events. I edited each time delay to .100 seconds and saved. The macro now works perfectly as intended and my hand will hurt far less.

Archived Post 05-05-2010 11:19 AM

I have no problems with my G19 macros working, but I mostly use those keys to launch AuotHotkey scripts.

As for Alt-something not working, that's due to a bug in the client. Alt gets 'stuck' sometimes when Alt-Tabbing out of the client. So if it's stuck, using a G13, G15, or G19 macro key with Alt-something bound to it would fire that 'something' with Alt modifier key in the up position. Same thing would happen if you tried to press Alt-something manually.

ukkorby 12-19-2012 06:30 PM

Thanks for this info, One of my division members if having trouble, hopefully this may solve it for him!


All times are GMT -7. The time now is 10:33 PM.