Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Feature Episodes, Events and PvE Content (http://sto-forum.perfectworld.com/forumdisplay.php?f=122)
-   -   Investigate Iconia is a HUGE waste of time (http://sto-forum.perfectworld.com/showthread.php?t=141700)

Archived Post 03-22-2010 06:11 AM

Investigate Iconia is a HUGE waste of time
 
I have had nothing but problems with this lame excuse for a quest.
First off, while flying through space, I have been randomly hitting invisible walls. Its not lag, and its not a graphics card issue, because I actually have to reverse engines to get around them. Next., all of the enemy's are spamming attacks. While fighting the Intrakhu, I was tractor beamed 3 times in a row which is total BS. Also, if I tried to tractor beam him, I would freeze not him. Plus he can some how magically drop all of my shields and weapons systems and spam torpedoes all at the same time. When you do finally get him down, he warps out and the mission doesn't progress beyond that point. Its it just me or is any one else having these problems.

Archived Post 03-22-2010 04:46 PM

sounds like you're just not very good...I doubt anything is bugged in your case

Archived Post 03-23-2010 02:44 AM

I had no problems at all with this mission. Nothing you described happend to me.

Archived Post 03-23-2010 09:24 AM

Quote:

Originally Posted by Hangover_Boy
sounds like you're just not very good...I doubt anything is bugged in your case

How can you say im not very good. I solo everythign because of rude losers like you. Get a life and stop trolling. I checked the some of the bug threads and others are having these issues.

Archived Post 03-23-2010 12:44 PM

Quote:

Originally Posted by brokendish (Post 2413806)
I have had nothing but problems with this lame excuse for a quest.
First off, while flying through space, I have been randomly hitting invisible walls. Its not lag, and its not a graphics card issue, because I actually have to reverse engines to get around them. Next., all of the enemy's are spamming attacks. While fighting the Intrakhu, I was tractor beamed 3 times in a row which is total BS. Also, if I tried to tractor beam him, I would freeze not him. Plus he can some how magically drop all of my shields and weapons systems and spam torpedoes all at the same time. When you do finally get him down, he warps out and the mission doesn't progress beyond that point. Its it just me or is any one else having these problems.

The only problem I've had that you mentioned, was the invisible wall. The rest didn't happen to me.

That said, the invisible wall issue happened to me on the "Ghost Ship" mission and one other that I can't remember. I think it's a random bug. I sent a bug report for it.

Having your shields and weapons drop are normal, based on the attack your enemey is using. Heck, that happens to be me fighting against most Battleships.

Archived Post 03-23-2010 11:28 PM

Quote:

Originally Posted by brokendish (Post 2413806)
I have had nothing but problems with this lame excuse for a quest.
First off, while flying through space, I have been randomly hitting invisible walls. Its not lag, and its not a graphics card issue, because I actually have to reverse engines to get around them. Next., all of the enemy's are spamming attacks. While fighting the Intrakhu, I was tractor beamed 3 times in a row which is total BS. Also, if I tried to tractor beam him, I would freeze not him. Plus he can some how magically drop all of my shields and weapons systems and spam torpedoes all at the same time. When you do finally get him down, he warps out and the mission doesn't progress beyond that point. Its it just me or is any one else having these problems.

you're simply bad at this a game.

you will see the intrakhu again soon.


All times are GMT -7. The time now is 06:45 AM.