Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Hotep IV (http://sto-forum.perfectworld.com/showthread.php?t=142509)

Archived Post 03-24-2010 09:50 AM

Hotep IV
 
At the very end of this mostly irritating mission (least fun experience in STO to date), I had to destroy those three Undine orbital weapons. When I get to the last one and the over-powered Undine battleship I had some game-breaking glitching going on.

I was able to silence the ship with jam sensors, and send the explosives to the platform, and then I tried to battle the ship so I could go rescue the fleeing shuttles. However, when I tried to travel a little bit away from the platform, I would glitch back to the platform... the end result of the whole mess was that it looked like the platform and the battleship were following me. The only way I was able to get out of this time warp (lol) was to blow up.

Archived Post 06-01-2010 07:15 PM

Your experience was posted some time ago. I just tried this mission last night and, once I got back into space, as I transferred the bombs to the orbiting weapons, Undine vessels would spawn nearby. They didn't give me too much trouble at first.

But, on the third/last orbiting weapon base, just as I transferred the bomb, two things happened at once!!!

1. There was a communication from one of the colonists asking--- PLEADING --- for assistance to the escaping shuttles..... all while....

2. That huge Undine Battleship was throwing everything including the kitchen sink at me!!

Like you...I tried to use Evasive Maneuvers and Ramming Speed to get away and back to the shuttles. Only to have that Undine ship also warp after me...and, where did I wind up? Right smack in the middle of trying to defend those shuttles against a Borg Sphere AND this Undine Battleship.

This mission definitely needs to be re-worked...at least once the ground/away mission is completed.


All times are GMT -7. The time now is 03:21 PM.