Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Rare Lt Commander ground items = no powers (http://sto-forum.perfectworld.com/showthread.php?t=144120)

Archived Post 03-26-2010 09:10 PM

Rare Lt Commander ground items = no powers
 
I have a rare personal shield and a rare phaser weapon. I noticed I was getting my butt kicked worse than usual and was hearing 'personal shield low' frequently. I went up against a Klingon commander and pulled out my rare weapon. Or so I thought. Suddenly I'm weaponless and just swinging punches at the Klingon. I think he stopped to laugh. Then I realized I had no shield. I had to steal a common personal shield from one of my away team just to survive.

It seems that the ground related rare items are broken.

Archived Post 03-27-2010 01:16 AM

I have this same problem. Happened only after I changed to the casual uniform. My personal Shield (Captain shield GREEN rarity I believe) always has -1 shield now. And one of the CAPTAIN sniper rifles with ??? as its secondary dps now does 0 damage for every shot. Changing uniforms, going to different shields and back, nothing works, the item is literally broken.

Archived Post 03-27-2010 02:47 AM

I also have this problem. I was wondering why I wasn't firing my main ground weapon only to find I was just throwing punches, despite the weapon being equipped. I tried de-equipping and re-equipping, as well as placing it in the other weapon slot, and neither worked. Strangely, if I'm using my other weapon, I can see the weapon icons for the problem one behind the normal icons on the action bar, but when I switch they just become punch icons.

The item is a Rare Disruptor Split Beam Rifle Mk III, and since this has happened only after the Season One patch I can only assume it has been caused by this. I have just noticed the server will be going down for maintenance at 10AM - will this (and any other) issues be addressed during this?

Archived Post 03-27-2010 02:55 AM

This is a known bug already it happens on Purple items and rares X grade aswell Devs are on it .

http://forums.startrekonline.com/sho....php?p=2445406
http://forums.startrekonline.com/sho....php?p=2448180

Archived Post 03-27-2010 07:46 AM

Quote:

Originally Posted by Shadow_Stranger
This is a known bug already it happens on Purple items and rares X grade aswell Devs are on it .

Good to hear, I've been getting this bug as well


All times are GMT -7. The time now is 02:54 PM.