Star Trek Online

Star Trek Online (
-   Builds, Powers, and Game Mechanics (
-   -   Why Can't I Train My Science BOFF? (

Archived Post 04-12-2010 01:06 PM

Why Can't I Train My Science BOFF?
When I decided to re-train one of my science BOFFs yesterday, I went to the trainer in Earth Starbase.
I selected the ensign-level skill to replace the old ensign-level skill.
Nothing happened.
I checked the chat log and it read: "Your bridge officer is learning a new skill"
Followed by: "Your bridge officer is no longer learning a new skill"
Can anybody tell me what would cause this?
BTW, I have plenty of credits for the transaction on hand and no deduction was made from the bank.

Archived Post 04-13-2010 07:11 AM

what is wrong with the training?
I have the same problem at the moment. I wanted to change a skill of one of my female bridge officers (her rank: commander). First i changed her space cmdr. skill to "viral matrix II". That worked fine. Then i wanted to change her space lt.cmdr. skill (which is still "viral matrix I"), but i cant. I get always the messages like Paratus6.

Further more, i cant even spend more bridge officer skill points to the changed "viral matrix II" skill. I get the message that it "interferes with her rank", but that cant be, because my science bridge officer was promoted to the rank of commander a long time ago, so that skill should be avaiable to her.

Like Paratus6, i have enough credits and skill points, so i am wondering now, why this is happening. :confused:

By the way: I was trying to change her skill with one of the other science bridge officers (the mission rewards), but that wasnt working either. The officer disappeard, but her skill is still the same. :(

Or is there maybe a limit of bridge officer points you can spend (in total or per rank)? My female science officer got 10000 points in total now, and i am at the rank of Captain 7. So maybe i can spend a little more points on here, if i am Admiral, but thats just a guess from me at this moment. Would be nice if someone could bring some light to this.

Archived Post 04-14-2010 09:11 AM

I have found a fix for this
I have found a fix for this.
I had the same issue with a Science BO.
I could not lvl up my skill for this Sci BO or change the ability. Till i tried changeing the 3rd tier space skill. After that it I could change any ability and put points in as well.
I belive the third tier space ability is the cause try training it to a differnt ability.

I know you said you tried to. But try the 3rd tier space and see if it works for you.

I have had 1 other person confirm that this worked for them as well.


We need a Live long and prosper hand symbol Icon/ smiley :cool:

All times are GMT -7. The time now is 11:45 PM.