Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Controls, User Interface, and the STO Gateway (http://sto-forum.perfectworld.com/forumdisplay.php?f=126)
-   -   Keybinds resetting after every load screen. (http://sto-forum.perfectworld.com/showthread.php?t=152955)

Archived Post 04-23-2010 11:54 PM

Keybinds resetting after every load screen.
 
It was OK to deal with for a bit, but constantly reloading my keybinds is just getting old.

The issue is only happening in space. My keymaps for my mouse buttons keep resetting after each loading screen. I've specifically remapped how the ship drives with the mouse. Instead of holding both buttons down, I can hold the right mouse button only and it shifts the position of the camera to follow. I have Rbutton set to +CamTurnToFace and both Right and left drag set to +CamMouseLook.

Any idea why they are resetting after each load? I have not noticed if there have been other changes in the keymap, but from what I can see, the keyboard goes unchanged.

Archived Post 04-25-2010 04:00 AM

After you get your keybinds set, try:
/bind_save_file default.txt

Your settings should stick after that. I think the game looks for default.txt in the live subfolder when it launches -- cryptic would need to verify that claim, but seems to work for me.

Something else to check:
Make sure that you dont save the keybind in a path that has different permissions than the game has. For example, saving the keybind to your protetected "Documents" folder or subfolders could cause a file access error on load if the game is running under different user credentials.
Try saving to the default path (leave the path out).

Archived Post 04-25-2010 08:40 AM

Sadly, no change. I'm still constantly reloading the keymap file... I have found if I try to make any kind of change to the space keymappings, they drop when I click OK on the options window. Ground keymap has continued to go unaffected.

As a matter of ease I keep the keymap files in the live directory as if I move them, I'll forget where I put them.

Archived Post 04-26-2010 04:26 PM

bad keybinds
 
Yeah i have the same problem and tried the fix above which didnt work for me either. I have reported this bug about 4 or 5 times with no response worth mentioning. I am not renewing after may 4th when my sub ends. Kind of disapointed with cryptic and how they ruined a franchise just by ignoring the little things. You know, like key binds, content, and ....oh yeah CUSTOMER SERVICE! Good Riddance.

gizmox64 11-21-2012 11:12 AM

Having the same issue, but after major patch, but as far as the load screen, yes but my Controls options keeps resetting.

Such as I turn off over the shoulder camera for ground, and it resets to on, sometimes immediately after I click off. It always resets on any load screen, and definitely does not carry from session to session. Plus the double tap to dive option in ground, will say off but I can still dive. I have to turn it on, save, then off, save and it will remember as long as I don't log off.
Why are these settings not saving? Some other commands do it too, like space, assist target (or target, targets target) basically if on and I target an ally, but have auto fire on, it will change back to the target, and my heal goes on me instead. This has to be checked every time I log in for both Space and Ground.

I saw the command for saving Key_bindings, so that will help, but Controls is just a on /off, and I don't see a way to export / load those on login/loadscreen.

I've submitted a ticket about 5 days ago, but no reply yet.

Any help?


All times are GMT -7. The time now is 11:57 AM.