Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Federation Gameplay (http://sto-forum.perfectworld.com/forumdisplay.php?f=165)
-   -   Loading Screen Transitions: Warp and Transporter (http://sto-forum.perfectworld.com/showthread.php?t=165902)

Archived Post 07-03-2010 11:51 AM

Loading Screen Transitions: Warp and Transporter
 
I'd like to make a suggestion for loading screens. Instead of having the pictures could you instead add a warp flyby transition? For example, when our ship approaches a system and we click enter, can a cluster of stars fade in and completely surround the ship as if we're flying at warp? And then once the area is loaded the map just fades in as the ship decelerates. And when we're beaming, could the screen turn blue and have some kind of transporter effect and then just fade out? I think this would be cool and easy to do and a lot of fans would find it more enjoyable than the current loading screen.:D Anyway, it's just a thought.

Archived Post 07-03-2010 12:53 PM

I totaly agree that would be awesome! I would also like to see when in sector space while in "warp": that we can see the streaming stars like the ones on the view screens when they go to warp. It would help give a sense of speed and make it feel more like warp than just big green/blue stars going by really slow. Also I don;t know if anyones else has seen this but when your in sector space if you make your camera point down you see TONS of mini white stars! maybe just bring those up? Either way I agree with the OP :cool:

Archived Post 07-04-2010 01:39 PM

During open beta, the game actually had a warp starfield and a transporter room loading screen, both animated. The devs removed them for some technical reason - performance optimization, I think. Still, I miss them, they were so much cooler than the static images we have now.

Archived Post 07-04-2010 05:01 PM

Quote:

Originally Posted by Marcellus (Post 2811405)
During open beta, the game actually had a warp starfield and a transporter room loading screen, both animated. The devs removed them for some technical reason - performance optimization, I think. Still, I miss them, they were so much cooler than the static images we have now.

I remember these. Didn't they have a flickering problem?

Archived Post 07-04-2010 05:10 PM

Why aren't they working to resolve issues with that current problem? That's what needs to be fixed. If they had it then they need to fix it. Not cut it out.


All times are GMT -7. The time now is 01:06 AM.