Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Controls, User Interface, and the STO Gateway (http://sto-forum.perfectworld.com/forumdisplay.php?f=126)
-   -   Number Keys Not Working (http://sto-forum.perfectworld.com/showthread.php?t=182439)

Archived Post 09-28-2010 12:17 PM

Number Keys Not Working
 
I warped into a star system and successfully killed a Raptor Escort with no UI/Control problems. More Klingons warped in, and I began fighting them. All of a sudden, I couldn't fire my torpedoes (hotkeyed to 2). I tried to Balance my Shields (3), but couldn't, then I tried to boost my shield strength (4), and nothing. I activated all my offensive buffs (Alt + 1, 2, 3, and 4), and I activated Evasive Maneuvers (Ctrl + 3), with no problems at all. Why was my bottom action bar unresponsive? In hindsight, I should've tried clicking them with the cursor, though since I have a laptop with no mouse, I never play that way anyway.

Archived Post 09-28-2010 03:11 PM

number lock on or anything by mistake?

Archived Post 09-29-2010 12:05 PM

I've been having this problem lately. In my case, it seems that the game thinks that alt or ctrl is pressed. When I press release alt or ctrl by itself, the problem usually fixes itself.

Archived Post 09-29-2010 03:50 PM

I have had that problem off and on. I'm not sure what is causing it, but it is very troublesome.

Archived Post 09-29-2010 06:38 PM

I've seen this happen occasionally as well. I finally tracked my particular issue down to the keybinds not completely resetting properly after Alt+Tabbing to a different app and then back to STO. Toggling away from STO and back again usually solved the problem for me.

Archived Post 01-21-2011 07:00 AM

Quote:

Originally Posted by NeilCell (Post 3063250)
I have had that problem off and on. I'm not sure what is causing it, but it is very troublesome.

Indeed, NeilCell. It is a very annoying bug and should be fixed ASAP... I mean, it's rather bothersome when circling an enemy starship, that you actually have to release your mousebuttons to manually click the skill you want to use; also, my numberkeys (1,2,3, etc.) seem to have been remapped to my officerskills; I've tried switching numlock off and on, alt-tabbing, nothing worked to fix this; please, anyone? Or is Cryptic already working on this? As for SFWriter13, I'll try using alt-tab again, if the problem persists, I'd really like some more advice on how to fix it... I'll keep you guys posted if I find anything out.

*EDIT* It seems that shutting down the game, and restarting it, also works- need more proof for this. Anyone?


All times are GMT -7. The time now is 10:45 AM.