Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   The Foundry for Star Trek Online - Discussion & Feedback (http://sto-forum.perfectworld.com/forumdisplay.php?f=204)
-   -   enemy wander issue: not wandering (http://sto-forum.perfectworld.com/showthread.php?t=191988)

Archived Post 12-05-2010 12:48 PM

enemy wander issue: not wandering
 
I'm trying to set enemies on a space map to wander. Currently, the setting are:

Wander speed: 24.9
Wander duration: 67.9
Wander weight: 20
Wander distance: 41.2
Wander idle time: 5
Wander path nodes: 15

Idle duration: 5
Idle weight: 1

any help would be much appreciated

Archived Post 12-05-2010 01:12 PM

Quote:

Originally Posted by SP3CTREnyc
I'm trying to set enemies on a space map to wander. Currently, the setting are:

Wander speed: 24.9
Wander duration: 67.9
Wander weight: 20
Wander distance: 41.2
Wander idle time: 5
Wander path nodes: 15

Idle duration: 5
Idle weight: 1

any help would be much appreciated

As far as I know you can't do anything about that yet. Probably should bring it up in the bugs section.

Archived Post 12-05-2010 03:05 PM

Sometimes it works and sometimes it doesn't. I sit and watch with similar settings to the OP and it seems it works on occasion.

Archived Post 12-05-2010 04:01 PM

Quote:

Originally Posted by SP3CTREnyc
I'm trying to set enemies on a space map to wander. Currently, the setting are:

Wander speed: 24.9
Wander duration: 67.9
Wander weight: 20
Wander distance: 41.2
Wander idle time: 5
Wander path nodes: 15

Idle duration: 5
Idle weight: 1

any help would be much appreciated

try lowering the duration too its minimum and increase the speed to compensate. my space guys wander.:eek:

Archived Post 12-05-2010 04:42 PM

Is this during preview ("Play Map" button) or after publish?

Wander is special in that it requires the pathfinding information be available. Since that is generated during publish, wander will do nothing during Preview before a Publish. If you publish your map, then it will work until you drastically change the map (thereby invalidating the pathfinding information).

Archived Post 12-05-2010 05:05 PM

Ahh ok thanks 8') It was the preview map. It DOES work on occasion in the preview map tho.


All times are GMT -7. The time now is 09:56 PM.