Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Klingon Gameplay (http://sto-forum.perfectworld.com/forumdisplay.php?f=166)
-   -   Mission question... (http://sto-forum.perfectworld.com/showthread.php?t=193807)

Archived Post 12-16-2010 06:39 AM

Mission question...
 
i have the mission...*removing the star empire blah blah* anyway its the one where you go to azure nebulua and scan the anomaly's and the go in and bash on rommys. Sadly i never get a kill count ever....i kill dozens and...the mi ssion never seems to progress....am i doin something wrong? or is it bugged?

Thanks

Archived Post 12-16-2010 06:41 AM

What mission is this?

Archived Post 12-16-2010 04:00 PM

This mission...i cant remember who gave it though as it was shared to me a bit back.

http://i6.photobucket.com/albums/y23...rommission.jpg

Archived Post 12-17-2010 02:01 AM

It's working for me at Commander Rank. Try cloaking and and waiting for a minute after you warp in. Sometimes it takes a minute for the kill counter (0/12) to come up. Once it comes up your good to go and can start engaging groups of Romulans. Hope this helps.

Archived Post 12-17-2010 06:10 AM

hmmm commander ya say? im ltcmdr 6 might that be the problem?

Archived Post 12-18-2010 09:35 AM

Quote:

Originally Posted by Liberty-Guard (Post 3230311)
hmmm commander ya say? im ltcmdr 6 might that be the problem?

I don't remember having been given that mission prior to LC10.

Archived Post 12-18-2010 11:25 PM

yea it was shared with me...thats why i asked that. Its prob the issue it dont recognize me as spose to have it and it wont update then.

Eh no biggy im just lookin for a khaless expanse kill count mission for my level so i can level some more....the little level 3 one dont cut the mustard for leveling :(


All times are GMT -7. The time now is 01:58 AM.