Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   The Foundry for Star Trek Online - Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=212)
-   -   possible bug (http://sto-forum.perfectworld.com/showthread.php?t=194923)

Archived Post 12-24-2010 05:54 PM

possible bug
 
I don't know if this has been experienced by anyone else, but I have my spawn point, and directly in front of it I have my reach marker with a popup that appears afterward. I hit full impulse and ... this is where it gets wierd ... the popup only appears about 2 out of every 5 attempts. A player has tried to access my mission twice, and each time, he wasn't able to trigger the the popup. I've tried to increase the size of the marker, i've moved the marker. I've reduced the marker's size. I've moved my spawn point. I made sure they were on the same plane. I've done everything I can think of. But it consistently acts inconsistent. Is this a bug? If it is please take note. Thank you.

Archived Post 12-27-2010 11:23 AM

How big is the marker?

If you accidentally spawn inside the marker (if it's that close), it won't trigger. You'd have to leave and then re-enter the marker volume to get it to trigger.

Is the marker integral to your story, or could you possibly replace it with a popup dialog to avoid this issue altogether? :)

Archived Post 12-27-2010 09:07 PM

Quote:

Originally Posted by ZeroniusRex
How big is the marker?

If you accidentally spawn inside the marker (if it's that close), it won't trigger. You'd have to leave and then re-enter the marker volume to get it to trigger.

Is the marker integral to your story, or could you possibly replace it with a popup dialog to avoid this issue altogether? :)

Thank you for your reply. it is much appreciated.

The idea behind my mission is that for some unknown reason we have dropped out of warp unexpectedly after the events of the first two missions in the story arc. So Enter the system. My spawn point is x-220.5, y-0.0, & z- -1117.9. The marker is suppose send the player to the interior of "their" ship, where they find an severely injured ensign. The marker is currently placed at x-220.5, y-0.0, & z- -1095.4.

The mission, Unholy Alliances III, is currently published. I've had one individual tell me twice that he couldn't trigger the marker to take him to his bridge. However, I have had two people successfully enter and finish the mission. They left some positive feedback. In my own testing, I was able to trigger it a few times, but most of my attempts were unsuccessful. I hope this helps you identify and resolve the issue.

I forgot one more thing... the radius of my marker is 10km currently.

Archived Post 12-28-2010 04:53 PM

10km is too small for a space marker--it would be simple to fly over or under or around it. I usually don't make space markers smaller than 100, personally. You could try that and see if that works. :)

Archived Post 12-28-2010 05:27 PM

Quote:

Originally Posted by ZeroniusRex
10km is too small for a space marker--it would be simple to fly over or under or around it. I usually don't make space markers smaller than 100, personally. You could try that and see if that works. :)

Might be wise to set 100 as the default. :)

Archived Post 12-28-2010 06:24 PM

I had some troubles with reach markers and reaching a ship in space... I copied the x,y, & z co-ordinates exactly and it seemed to fix it.

I also had one like you described with a spawn point and a reach marker... used exactly identical co-ordinates and it seemed to work better. I had a similar use in that is was an interrupted transwarp... and the character get's a series of pop-up messages and then moved to a dream sequence with another map change... giving the illusion of interrupted transit from one location to another with drama and action in between.

I used the green tubular worm-hole map to simulate the transwarp field, but have seen flowing stars used as well...

Archived Post 12-28-2010 11:30 PM

I increased the marker to 100 and moved it outside of the spawn point. This seemed to fix the problem. I haven't had to do very much testing though. The changes have published. I'm hoping to try it out tomorrow.

Archived Post 12-28-2010 11:31 PM

Quote:

Originally Posted by Napoleon_BlownApart
I had some troubles with reach markers and reaching a ship in space... I copied the x,y, & z co-ordinates exactly and it seemed to fix it.

I also had one like you described with a spawn point and a reach marker... used exactly identical co-ordinates and it seemed to work better. I had a similar use in that is was an interrupted transwarp... and the character get's a series of pop-up messages and then moved to a dream sequence with another map change... giving the illusion of interrupted transit from one location to another with drama and action in between.

I used the green tubular worm-hole map to simulate the transwarp field, but have seen flowing stars used as well...

Thank you for your suggestions. I have taken them under advisement, and have made some changes to the mission.

Archived Post 12-30-2010 10:54 AM

Quote:

Originally Posted by the_illustrious_q
Might be wise to set 100 as the default. :)

That's a good idea. :)

Archived Post 12-31-2010 10:34 AM

mission seems to be working properly now. Thank you.


All times are GMT -7. The time now is 11:41 PM.