Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   The Foundry for Star Trek Online - Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=212)
-   -   [BUG] Periodic Mission Search Loss (http://sto-forum.perfectworld.com/showthread.php?t=195166)

Archived Post 12-27-2010 12:10 PM

[BUG] Periodic Mission Search Loss
 
Background:
I was searching for content, determining whether something ahd been reviewed or not, using a massive list of missions (mostly) known to be published.

However, I noticed that running search after search would sometimes cause me to be unable to find a mission I had found just moments prior.
Replication Steps:
  • Use a list of known-to-be published missions (not just my list)
  • Run search after search until one of them drops
Theorized Causes:
  • Too many calls to the search index is causing search loss
Detailed Chat Log with Zero:
Quote:

[TheFoundry] Zero@ZeroniusRex: How are things looking? Everything stable over the weekend? :)

[TheFoundry] Jack 1@Darren_Kitlor: Search is broken

[TheFoundry] Zero@ZeroniusRex: As of when? It was just working for me. (First thing I checked this morning.)

[TheFoundry] Jack 1@Darren_Kitlor: When running multiple searches, I'm not encountering the unable to search for bug anymore

[TheFoundry] Jack 1@Darren_Kitlor: However, I noticed that some mission you can find then after a few searches, can't find them by name or author

[TheFoundry] Zero@ZeroniusRex: So if I run a specific search, it works. Then run a different one and it won't?

[TheFoundry] Jack 1@Darren_Kitlor: It's a bit more complicated

[TheFoundry] Zero@ZeroniusRex: Are there exact steps that makes this reproducible every time?

[TheFoundry] Zero@ZeroniusRex: Or does it seem somewhat random?

[TheFoundry] Jack 1@Darren_Kitlor: At random, i think it's data loss from the search

[TheFoundry] Jack 1@Darren_Kitlor: It comes and goes

[TheFoundry] Jack 1@Darren_Kitlor: without needing to stop reviewing

[TheFoundry] Jack 1@Darren_Kitlor: So, this part is new - before you had to stop and start to find it reliably

[TheFoundry] Zero@ZeroniusRex: Are there any posts about this on the forums that you know of?

[TheFoundry] Jack 1@Darren_Kitlor: I can't find it but most people are running search after search

[TheFoundry] Jack 1@Darren_Kitlor: I was running through the big mission list on Tribble to find unreviewed missions

[TheFoundry] Zero@ZeroniusRex: hmm i wonder if that's part of the issue

[TheFoundry] Jack 1@Darren_Kitlor: It might be too many calls to the search engine and it causes data loss

[TheFoundry] Jack 1@Darren_Kitlor: Not everyone does 30+ searches in a row

[TheFoundry] Zero@ZeroniusRex: well, the data is still there, right? you can always re-find something eventually if you're persistent?

[TheFoundry] Jack 1@Darren_Kitlor: Yes

[TheFoundry] Zero@ZeroniusRex: is it only failing when you search in unreviewed content?

[TheFoundry] Jack 1@Darren_Kitlor: So, my guess is server straing for the search index

[TheFoundry] Jack 1@Darren_Kitlor: For any content, it happens periodically

[TheFoundry] Zero@ZeroniusRex: could it be as simple as the content no longer being "unreviewed"

[TheFoundry] Zero@ZeroniusRex: ah ok

[TheFoundry] Jack 1@Darren_Kitlor: Like I said, I was searching through the big list I'm maintaining on the Foundry Open beta forums

[TheFoundry] Jack 1@Darren_Kitlor: most were reviewed and I've caused both unreviewed and reviewed to disappear from searching

[TheFoundry] Jack 1@Darren_Kitlor: but it unreliable since they can reappear

[TheFoundry] Zero@ZeroniusRex: would you be willing to make a post about this on the foundry bug forums so i have something i can send to the devs?

[TheFoundry] Jack 1@Darren_Kitlor: I think searching might be overwhelming the index

[TheFoundry] Jack 1@Darren_Kitlor: Yes

[TheFoundry] Jack 1@Darren_Kitlor: Working on it now

Archived Post 12-27-2010 12:11 PM

Oh no! He called me out!

Thanks for making this, Darren. :)

If anyone else sees this and knows of some solid steps to make searches fail, I'd love to hear about it. :D

Archived Post 12-29-2010 12:24 AM

Quote:

Originally Posted by ZeroniusRex
Oh no! He called me out!

Thanks for making this, Darren. :)

If anyone else sees this and knows of some solid steps to make searches fail, I'd love to hear about it. :D

right now- I have lost all missions in the community authored tab.

In fact, mashing the search button doesn't help me either, nor does trying to filter via newest/most popular/ and whatnot.

I have tried all my old tried and true methods of recovering the ability to get missions in community authored(that is unbecoming and becoming a reviewer again, mashing lists, logging off tribble, onto foundry, then back onto tribble on a different toon again) tab, but so far- nuthin

Archived Post 12-30-2010 06:16 AM

Quote:

Originally Posted by apt.pupil
right now- I have lost all missions in the community authored tab.

In fact, mashing the search button doesn't help me either, nor does trying to filter via newest/most popular/ and whatnot.

I have tried all my old tried and true methods of recovering the ability to get missions in community authored(that is unbecoming and becoming a reviewer again, mashing lists, logging off tribble, onto foundry, then back onto tribble on a different toon again) tab, but so far- nuthin

Same deal for me. Can't get a single mission to show up in the search window for either community authored or review content, no matter what I do. It's been like this for a few days now.

Archived Post 12-30-2010 10:37 AM

Quote:

Originally Posted by apt.pupil
right now- I have lost all missions in the community authored tab.

In fact, mashing the search button doesn't help me either, nor does trying to filter via newest/most popular/ and whatnot.

I have tried all my old tried and true methods of recovering the ability to get missions in community authored(that is unbecoming and becoming a reviewer again, mashing lists, logging off tribble, onto foundry, then back onto tribble on a different toon again) tab, but so far- nuthin

Ditto for me, been that way since around 6:18 PM PST Tuesday evening (12/28/10)

Archived Post 12-30-2010 11:41 AM

Search doesn't seem to be functioning at all right now, but that's a different issue than the one Darren refers to here. Sort of. Maybe.

Archived Post 12-30-2010 01:36 PM

Quote:

Originally Posted by ZeroniusRex
Search doesn't seem to be functioning at all right now, but that's a different issue than the one Darren refers to here. Sort of. Maybe.

Unless the searches were slowly reducing to no searches working. Oh god! Inverse exponential functions!

Seriously though, this thread is going to be investigated more on my part once searching comes back up.

Archived Post 12-30-2010 05:21 PM

It's back up again, in case you didn't see already. :)

Archived Post 01-03-2011 02:57 AM

Behavior of Foundry search engine is erratic. Search field appears to be sensitive to completed words only; i.e., 'proc' will make no missions appear, but 'proclaim' will make my entire series appear. Multiple publishes result in multiple iterations of the mission in the search list. Some missions which have been reviewed several times are still under "Review Content'. Revoking & immeidately renewing one's reviewer status makes the engine more responsive.

Archived Post 01-03-2011 12:08 PM

Quote:

Originally Posted by AzureAlliance (Post 3259938)
Multiple publishes result in multiple iterations of the mission in the search list.

Does this only occur if you already have the mission that's being republished? I haven't been able to replicate this behavior at all.

Quote:

Some missions which have been reviewed several times are still under "Review Content'.
What is "several"? Also, it's possible that the mission was republished and thus needs to go through the review process again--does this seem like a likely scenario?

Thanks!


All times are GMT -7. The time now is 08:43 PM.