Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Feature Episodes, Events and PvE Content (http://sto-forum.perfectworld.com/forumdisplay.php?f=122)
-   -   Mis-Fires (http://sto-forum.perfectworld.com/showthread.php?t=209189)

Archived Post 03-28-2011 06:18 PM

Mis-Fires
 
Ok...I have GOT to know....


After this long why has the misfire issue of Torps and Mines NOT been addresses yet? This is a serious issue. I can deal with an "incorrect texture" on my uniform ffs...just get me a torpedo that doesn't auto-cooldown w/o firing!!!!!

Archived Post 03-28-2011 06:23 PM

A while ago they had actually fixed the issue. I recall seeing it in patch notes and I remember Tricobalt Torpedoes specifically finally firing 100% of the time. However, in the subsequent patch they broke it again. I still don't recall seeing the issue of bridge officer powers failing to activate and going on a 50% cool down having been addressed. And of course we still have to pound a key multiple times in order to make sure it fires at all.

But at least we can look cute in our skirts and sit in some chairs. ^^

Archived Post 03-28-2011 06:28 PM

And don't forget we can get the TOS phasers in the C-store now.

Archived Post 03-31-2011 06:17 AM

I noticed this during Infected yesterday as well. I thought i was just hitting the keys to fast for the game choking the commands off before the system could recognize that the ability had been activated but instead I was having to spam keys to get the abilties to work.

Archived Post 04-02-2011 06:17 AM

I still see it happen on torpedoes now and then but quite rare compared to the past. Usually it happens if I try to fire the torpedo right as its cooldown is expiring or too quickly after hitting a torpedo skill like High Yield.

Archived Post 04-02-2011 12:59 PM

True, and there is still a normal mis-fire issue. I'm lucky to get off a Tricobalt normally.

Then there is this new FAW issue that destroys the torpedo, even if you successfully fire one off. So practically they are useless now.

Archived Post 04-05-2011 03:01 AM

I've used Plasma beams on lower tier ships,they tend to misfire if you use FAW or BO.

Archived Post 04-06-2011 04:25 AM

One of the odd things that seems to happening occassionally is that a power mis-fires in the way that it even seems to show the animation, but afterwards it turns out nothing happened (not even the cooldown). I've seen that happen with Charged Particle Burst. I had the feeling it might be related to my current target leaving an arc or range of a power - even with powers that don't care what my current target does (CPB for example again.)

Archived Post 04-06-2011 07:03 AM

Quote:

Originally Posted by SteveHale (Post 3460372)
But at least we can look cute in our skirts and sit in some chairs. ^^

Hale....you forgot polishing our new belt buckles too :p

Archived Post 04-14-2011 10:04 PM

Quote:

Originally Posted by Admiral_Joslin (Post 3476075)
Hale....you forgot polishing our new belt buckles too :p


I would be happy if they fixed the timer for the trics. I am constantly getting an "additional" 30 sec cooldown, It really isn't another 30 seconds the timer is resetting the power but when you trigger it, it continues the final 30 seconds.


All times are GMT -7. The time now is 01:04 AM.