Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   PvP Gameplay (http://sto-forum.perfectworld.com/forumdisplay.php?f=125)
-   -   I see you :P (http://sto-forum.perfectworld.com/showthread.php?t=222332)

Archived Post 07-05-2011 05:59 PM

I see you :P
 
I don't PvP very often, exception being with fleetmates or Kerrat. Now during Kerrat, no matter what side I'm playing (fed or kdf) I can see the cloaked ship incoming due to high aux or skills, I see them come right up to me, buff and then open fire.

Why is it that if I can 'see' them, I can't target them, unless I use skill that will decloak them? I've tried clicking on them manually, but seems to no avail.

Did I miss a mechanic on this? Or is the only way to force de-cloak with an AOE skill, ie photonic shockwave, grav well, tykens, or mines for example?

I'm not greifing that this goes on, just feel that if I worked hard to see them before they see me, I should be able to open fire without using the force de-cloak skills.

Archived Post 07-05-2011 06:29 PM

use faw until it gets fixed

Archived Post 07-05-2011 07:08 PM

Use fireworks. That scares those lousy Klinks off every time:cool:

Archived Post 07-05-2011 07:18 PM

Quote:

Originally Posted by Captain Data
use faw until it gets fixed

Until the skill or ability to click on them gets fixed?

Archived Post 07-05-2011 07:25 PM

Quote:

Originally Posted by amidoinitright (Post 3625856)
Use fireworks. That scares those lousy Klinks off every time:cool:

Not that helpful, though I appreciate the humor. I notice this more in my carrier, where I run high aux, a defiant or galaxy x comes alongside, but I can't mouse click, or tab select them to open fire.

I also experience this when I'm in my fed ships, a bop or raptor comes alongside, same thing can't click to fire unless they decloak or skill forces decloak.

I'd this working as intended? Or is a fix on its way?

Archived Post 07-05-2011 07:33 PM

just hit your spacebar with no target selected, this should fire at the closest target. I know that I've been shot out of cloak a few times.

Archived Post 07-05-2011 08:01 PM

I find it odd that you are having this problem. I've never seen that happen personally. Usually if I see a target who's Cloaked/MESed I can target them and shoot at them as long as I'm quick enough. I can't say I am sure on the problem you are having though.. Maybe you have a setting wierd?

Archived Post 07-05-2011 08:27 PM

Hm, I've never had an issue of not being able to target them without using a decloak ability. Does this happen all the time, or only under certain circumstances?

Can you see them for more than a few seconds while clicking? What could be happening is that you see them, but they're already moving out of detection range while you're trying to click/target them and they're in that "fading away" process.

Archived Post 07-05-2011 08:52 PM

Just tested with a fleetmate, 1v1. Using my carrier and afterwards my escort. Full aux. Parked right next to me, saw him coming from 7km away. All beams on carrier, couldn't fire. Asked to fire his buffs, I can see everything, but til he drops cloak, or I use a de-cloak skill, can't target and fire.

Archived Post 07-05-2011 10:09 PM

Quote:

Originally Posted by FenixSS (Post 3625958)
Just tested with a fleetmate, 1v1. Using my carrier and afterwards my escort. Full aux. Parked right next to me, saw him coming from 7km away. All beams on carrier, couldn't fire. Asked to fire his buffs, I can see everything, but til he drops cloak, or I use a de-cloak skill, can't target and fire.

As a science captain, who runs on high aux, I can attest that this, has happened to me too. I figured it was
intentional, so I wouldn't have the upper hand on an un-shielded cloaked ship.


All times are GMT -7. The time now is 08:36 AM.