Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Tribble - Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=229)
-   -   Space Combat - error or lag? (http://sto-forum.perfectworld.com/showthread.php?t=233209)

Archived Post 09-29-2011 08:10 PM

Space Combat - error or lag?
 
So I've noticed that the shield strike animation seen in space combat is off, usually by 90 degrees. I was thinking at first it was just stress and lag on the test server, but the "lag" isn't right...

For example I hit a ship full broadside with phasers on its shielded right side - the enemy ships shields make the impact glow animation on the belly of the ship. Another time, phaser broadside hits the nose of the enemy ship, the shield impact glow flashes briefly on the port side.

Also the same thing is happening on my ship when I am hit. I've even been hit on the front and the shield flashes on the rear! Just to be clear btw I am talking about the actual shield glow being off, NOT the shield levels as displayed in the HUD.

Archived Post 09-29-2011 08:34 PM

Ive seen this behavior since i played this game since December last year.
Its just totally illogical on how the shields behave versus incoming (phaser) fire.

I would like to see real effects like on the show, more, faster paced phaser fires (Like Fire at Will is right now) and with the proper shield animation effects.

The weird animations you see when phasers hit you (not the shield lighting up itself) but a weird circle like thingy which looks really, really odd...

Archived Post 09-30-2011 06:08 AM

Quote:

Originally Posted by Marctraider (Post 3781193)
Ive seen this behavior since i played this game since December last year.
Its just totally illogical on how the shields behave versus incoming (phaser) fire.

I would like to see real effects like on the show, more, faster paced phaser fires (Like Fire at Will is right now) and with the proper shield animation effects.

The weird animations you see when phasers hit you (not the shield lighting up itself) but a weird circle like thingy which looks really, really odd...

It is fine for all of my characters (last I checked) on Holodeck...this starter zone playthrough is the first I noticed it and I find it EXTREMELY distracting; this is because I get hit on the left shield, then I see a right side glow...so I swing my camera that way to see who else is shooting at me...no one :mad:

Archived Post 10-01-2011 01:27 AM

Same, I don't remember having this on holodeck, but on the F2P build its very apparent.


All times are GMT -7. The time now is 02:44 AM.