Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   Keyboard not responding (http://sto-forum.perfectworld.com/showthread.php?t=248022)

Archived Post 01-12-2012 04:41 PM

Keyboard not responding
 
I have a Merc Stealth keyboard from steelseries and up until the past few days everything has been fine and dandy. Now after playing STO for a few mins the keyboard stops responding meaning the only way to control anything is the mouse.

I do not have xfire installed and steam is not running when I run STO. My keyboard drivers are updated. I would appreciate any help anyone could offer on this issue.

Update I used Win7 Home premium 64bit edition.

Archived Post 01-12-2012 08:44 PM

Restart your PC and network hardware first, then try again.

If you are using any programmable keys with custom keybinds, try not using them or disabling them and see if it is just the programmable keys acting up on you.

If you have any macros setup for any functions with the game, disable those.

Double check your keybinds, and if the keyboard drivers have profiles for games that you can save and setup, check to see that such a file isn't corrupt or make a new one and see if that works.

Try using the keyboard on another PC with the updated keyboard drivers and see if it still works properly for the game (if you can).

Archived Post 01-12-2012 08:52 PM

I've been having a similiar issue with my keybinds and power bar. It stopps responding to commands in ground STF's. The only way to reset it is to log out and then log back in. When this happens I cannot use any powers or actions with either keybinds or by clicking with the mouse. the only thing I'm able to do is move around.

Archived Post 01-12-2012 09:08 PM

I have a merc stealth series keyboard and the culprit of most of these keyboard attacks is the STF KA. Theres a couple work arounds for it. The first one is double tap your scroll lock button and it usually frees up or restores your keyboard. Int he instances that wont work alt+tab from one program back to sto client and that most of the time restores the keyboard controls. The keys that have an issue are that when you hit 1 through 0 on your keyboard it will activate the Alt+Keys skills instead. Hope that helps out.

Archived Post 01-12-2012 09:24 PM

Nice, thanks for sharing the information!

We have much to learn about STO intricacies, and this helps ;)

Archived Post 01-12-2012 09:35 PM

You are very welcome do you also deal with issues like this with certain instances freezing up the client when you get to a certain part? I know one annoying glitch in erikson system in pi canis area that could use a fix.

Archived Post 01-12-2012 09:39 PM

If there is a bug report menu option that you can use in the in-game support, use it before they switch it off over to our current web browser based system. That will get it to the devs faster if a legit bug.

When reporting bugs, it is helpful to give as much info as possible leading up to, and how to reproduce the bug.

Thanks!

Archived Post 01-13-2012 04:53 AM

Thanks for everyone's help I'll try some of these things the next time it happens and see what happens... to expand on my original post the problem has repeated itself several times even after a total system reboot and I haven't done the STF KA. With this problem none of the keyboard option work even hitting escape to log out/exit the game only responds after repeated tapping.

Archived Post 01-13-2012 06:29 AM

I stopped doing bug reports when I would get messages back such as ask someone in the forums, we cannot recreate that issue, or just closed it with no reponse, basically telling me not to waste their time. Only support I ever recieved was putting these thru the forums.

Archived Post 01-14-2012 05:32 AM

And it happened again just a few mins ago... seems to happen everytime I play no matter what mission. Mid-way though my keyobard controls just quit. I am not running a macro and I have tried all the solutions presented here. The whole keyboard goes dead in game very frustrating as it makes the game pretty much unplayable.


All times are GMT -7. The time now is 08:01 AM.