Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Federation Shipyards (http://sto-forum.perfectworld.com/forumdisplay.php?f=218)
-   -   Efficient impulase engines scaling properly? (http://sto-forum.perfectworld.com/showthread.php?t=248489)

Archived Post 01-16-2012 09:06 AM

Efficient impulase engines scaling properly?
 
Yesterday I got my hands on the Efficient Impulse Engines; something I had been looking forward to for a while. :)

Thing is though, I got the Mk VI version, and aside from the bonuses to my power settings, the displayed stats were exactly the same as the Mk IV common engines I was replacing. :confused:

This could mean one of 3 things:
  1. There is a display error showing the wrong stats.
  2. The engines themselves are not scaling to level properly.
  3. Efficient Impulse Engines are rubbish.

Anyone know which it is?

Archived Post 01-16-2012 10:30 AM

Might help if you post what they are giving you.

Archived Post 01-16-2012 12:56 PM

Quote:

Originally Posted by Manx (Post 3950897)
Yesterday I got my hands on the Efficient Impulse Engines; something I had been looking forward to for a while. :)

Thing is though, I got the Mk VI version, and aside from the bonuses to my power settings, the displayed stats were exactly the same as the Mk IV common engines I was replacing. :confused:

This could mean one of 3 things:
  1. There is a display error showing the wrong stats.
  2. The engines themselves are not scaling to level properly.
  3. Efficient Impulse Engines are rubbish.

Anyone know which it is?

Not a shock..
Heck, I have a MK XII Quatum Torpedo that says its a Mk XI in the descrtiption, but has the XII's stats.

I was under the beliefe that all the "efficient" engines had the same stats anyways


All times are GMT -7. The time now is 10:39 PM.