Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Ten Forward (http://sto-forum.perfectworld.com/forumdisplay.php?f=129)
-   -   Wait.. What? Star Trek Champs online?!?! (http://sto-forum.perfectworld.com/showthread.php?t=248661)

Archived Post 01-17-2012 05:29 AM

Wait.. What? Star Trek Champs online?!?!
 
I think the screenshot speaks for itself...

http://anazonda.com/wtf.jpg

I visited the champs website just before the STO one... and was... WTF. xD

The logo goes really well with the STO site though

Archived Post 01-17-2012 05:36 AM

haha, thats awesomely epic fail, but yeah the logo works with the new site design, maybe they put the design on the wrong website

Archived Post 01-17-2012 05:39 AM

Quote:

Originally Posted by Lonesamurai (Post 3952915)
haha, thats awesomely epic fail, but yeah the logo works with the new site design, maybe they put the design on the wrong website

Probably more a cache lag of some kind on my PC... Still funny though.

Archived Post 01-17-2012 08:19 AM

When I deleted STO and loaded it on steam again, I noticed the icon was still on my desktop, so I clicked it, it loaded up Champions.

Archived Post 01-17-2012 08:51 AM

Quote:

Originally Posted by anazonda (Post 3952920)
Probably more a cache lag of some kind on my PC... Still funny though.

having said that though, I actually just had the same issue on my websites after a server restart, some of the server cache was a little screwy and still cleaning it out now, so probably on their end


All times are GMT -7. The time now is 04:08 AM.