Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   Launcher Crashes Upon Login (http://sto-forum.perfectworld.com/showthread.php?t=248778)

Archived Post 01-17-2012 04:39 PM

Launcher Crashes Upon Login
 
First time running STO, wanted to try it since it went F2P.

Tried Logging in, launcher crashes.
Gave the executable Admin privileges, still crashes on login

Pastebin with DXDIAG report:
http://pastebin.com/BB0J8x0K

I must have a dozen crash reports on the server by now.

Anyone know what to try next? I'm stumped at this point.

Archived Post 01-17-2012 09:46 PM

Try updating your CPU, mainboard, and video drivers.

Please restart your PC and network hardware first.

You may have to be on a Windows Admin account, or have Run as Admin access to be able to download, install, update, and run the game. If on Windows Vista or 7, you may have to change the level of your UAC settings or turn them off temporarily.

You may need to update or install the latest Microsoft Visual C++ Redistributable. You may need to update your version of Windows and also update to the latest version of DirectX. You may also need to check or change your network settings.

You can try adding the game folder/files to your exceptions list in your antivirus and firewall software. Please see the help menu or support website for the software that you use if you aren't sure how to do it.

At your own risk, you may have to disable your antivirus, firewall, and other security software temporarily while you download, install, update, login to, and play the game. Sometimes the security software will block it or throttle it, no matter what you try or even if you try to add exceptions for the game files in your security software.

You may also have to disable, shut down, uninstall, or disable any: torrent, keyboard/mouse, web browser toolbars, video/screen capture, gamepad/input device, multimedia, Instant Messaging, voice over IP, web browser games, other games software applications before downloading, installing, updating, logging into, and playing the game. Basically shut down all non-essential programs.

If you need further help, when you contact us by a support ticket, please answer the following questions:

What exactly did you try in the information presented to you?

What changes to your software did you make?

What errors did you get?

Archived Post 01-18-2012 07:56 AM

I am getting the same exact issue. The very first time I tried to login, the login crashes. I entered my username and password, clicked submit, and it crashes every time.

Archived Post 01-18-2012 08:14 AM

I have had some success, I got the launcher to stop crashing. It seems to be something to do with programs running in the background. I have several that I use on a regular basis, so I will try and see if I can narrow down the culprit.

Programs I typically have running:
Dropbox
Teamviewer
Chrome
Universal Remote Client
nvidia tray icon
realtek audio icon

I'll keep you posted.

Archived Post 01-18-2012 08:40 AM

you get any error message screen on crash?

Archived Post 01-18-2012 09:29 AM

Got the same problem.

You need to close TeamViewer application. After this, the launcher works.


Greetings.

Archived Post 01-18-2012 09:42 AM

Quote:

Originally Posted by GaRReTT2k (Post 3955587)
Got the same problem.

You need to close TeamViewer application. After this, the launcher works.


Greetings.

^ This.

TeamViewer 7 causes an issue with the Patcher crashing if you have the QuickConnect button enabled, but luckily you don't have to close TeamViewer entirely. To switch it off, open Team Viewer, go to Extra -> Options, followed by choosing the Advanced Tab, clicking the QuickConnect Configure button, and then unchecking the Show QuickConnect option. The standard patcher will work fine after that. You may be able to blacklist only that application and have it work fine, but I haven't personally tested it. And yes, I also spent a few days redownloading the entire client (twice!) because I had forgotten I'd turned QuickConnect on. Oops! :o

Goodluck!

Archived Post 01-18-2012 06:35 PM

Quote:

Originally Posted by Paradine
^ This.

TeamViewer 7 causes an issue with the Patcher crashing if you have the QuickConnect button enabled, but luckily you don't have to close TeamViewer entirely. To switch it off, open Team Viewer, go to Extra -> Options, followed by choosing the Advanced Tab, clicking the QuickConnect Configure button, and then unchecking the Show QuickConnect option. The standard patcher will work fine after that. You may be able to blacklist only that application and have it work fine, but I haven't personally tested it. And yes, I also spent a few days redownloading the entire client (twice!) because I had forgotten I'd turned QuickConnect on. Oops! :o

Goodluck!

Worked like a charm! Apparently the launcher doesn't like having the Teamviewer quicklaunch button added to it. Disabled it in Teamviewer, and ran on the first try. Thanks a ton! Now to figure everything else about this game xD

Archived Post 01-19-2012 01:42 AM

Quote:

Originally Posted by TheGeek0
Worked like a charm! Apparently the launcher doesn't like having the Teamviewer quicklaunch button added to it. Disabled it in Teamviewer, and ran on the first try. Thanks a ton! Now to figure everything else about this game xD

Works for me to. Shuting down TeamViewer7 and the loader is running fine.


All times are GMT -7. The time now is 01:16 AM.