Star Trek Online

Star Trek Online (
-   C-Store, ZEN, and Promotions (
-   -   no buy with steam (

Archived Post 02-11-2012 06:02 PM

no buy with steam
cant buy points through steam. any reason why?

Archived Post 02-11-2012 06:12 PM

I'm curious about this as well. I'd made a couple point purchases with my steam account recently and had no difficulties. I tried to make a transaction today and ended up in a looping runaround that kept taking me to zen.

Archived Post 02-11-2012 06:59 PM

Yes I have been having this problem as well, before the steam purchase worked fine but now I cant seem to do it.

Archived Post 02-11-2012 07:56 PM

yesterday, i was able to purchase c-points with cash from my steam wallet. Today however i was unable to do so. It now redirects to the star trek online page.

Archived Post 02-11-2012 08:17 PM

Y U No Work?!?
Same here folks, I made a purchase of C-points yesterday to get some keys and try some of these boxes* with no dramas. As I have been enjoying the game so far, I thought I would expand my inventory and crew slots. I tried to buy the C-points the same way I did yesterday and also kept getting linked out to the Perfect World website.

I'm not going to keep feeding my CC number into every site that asks for it, Steam already works, it was good enough yesterday so what is the deal now?

*quite dissapointing TBH, but that's for another thread. Save yourself the dissapointment and put your $$ into something better. :)

Archived Post 02-11-2012 08:42 PM

Same here. I Just made Commander tonight. I want my excelsior! But I'm not plugging my CC into anyone elses website and I wont waste my promotion ship selection on that 4 nacelle monstrosity. Its ugly and its gimped.

Archived Post 02-11-2012 08:45 PM


Originally Posted by Rehpic
Steam had an outage earlier today that caused us to disable payment via steam wallet. It should be re-enabled soon.

From this thread -

Archived Post 02-12-2012 10:09 AM


Thanks for the response. It seemed strange if there was an official policy change that there was no announcement. Glad to see it was a glitch in the system.

All times are GMT -7. The time now is 12:21 AM.