Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Feature Episodes, Events and PvE Content (http://sto-forum.perfectworld.com/forumdisplay.php?f=122)
-   -   The House doesn't always win (http://sto-forum.perfectworld.com/showthread.php?t=257896)

Archived Post 02-28-2012 04:24 PM

The House doesn't always win
 
I am working on the Klingon mission "the House always wins" and I have run into a problem. I destroyed the first satellite, then frieghter, second sateilite, then frieghter. third Satellite.... and no third frieghter. I saw it briefly before a raptor escort attacked and eventually killed me, and now it is gone, I can't find it anywhere?

How do I find it, or continue on? am I doomed to repeat the whole episode over again?

Archived Post 02-28-2012 04:34 PM

Quote:

Originally Posted by voyagerfan9751
I am working on the Klingon mission "the House always wins" and I have run into a problem. I destroyed the first satellite, then frieghter, second sateilite, then frieghter. third Satellite.... and no third frieghter. I saw it briefly before a raptor escort attacked and eventually killed me, and now it is gone, I can't find it anywhere?

How do I find it, or continue on? am I doomed to repeat the whole episode over again?

Try using the "V" key to scan for anomalies and/or mission objectives. Eventually you should find the freighter.

Archived Post 02-28-2012 05:48 PM

I tried using "V" and I stilll can't seem to find it. I points out the anomalies in the area. and when I get the two that are there, I get "0 anamolies in the area" and still no frieghter

Archived Post 02-28-2012 05:58 PM

Did you destroy the third freighter before the third satellite? That could've messed it up.

Exit to sector and then try again. Be careful not to destroy any of the freighters until it's in your mission objectives.

Archived Post 02-28-2012 07:26 PM

Yes, I have always destroyed the Satellite before going after the frieghter. Honestly, I have not found it difficult not to, as the frieghters are rather far from their respective satellites. You really have to look for them.

here is what usually happens. I destroy the third satellite, go after the third frieghter, I am then attacked by two or more Raptor Escorts while trying to destroy the frieghter, so I switch to going after the escorts. I get killed by the escorts anyways. When I respawn and return to the area, the frieghter is now no where to be seen. I have the little glow area on the map that says where the frieghter is suppose to be, and my game hasn't continued (indicating the frieghter has been in fact destroyed) but still no more frieghter.

Archived Post 02-28-2012 07:31 PM

You meant the "destroy third freighter" goal is highlighted green?

The freighters start to move when you get close. Next time try luring the Raptors away one at a time before getting close to the transport. If it starts moving anyway, make a mental note of which way it's going so you have a better chance of finding it again.

Archived Post 05-22-2012 12:04 AM

i am also having a problem with the second mission on the klingon side it keeps laging on me so i had to skip it i got most of my graphis set to low but i can run the other missions and games with out the lag is it just this mission if any one can help let me know

Archived Post 05-22-2012 12:14 AM

Yeah this mission caused frame rate hell for me till upgraded my graphics card. The way I tend to do it is drop the satelites first then just go back and pop the freighters one at a time, sneaking up on them with battle cloak/cloak, getting weaps all ready, decloak, blow them to hell then worry about the incoming flak before moving on and repeating...


All times are GMT -7. The time now is 05:42 AM.