Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Federation Shipyards (http://sto-forum.perfectworld.com/forumdisplay.php?f=218)
-   -   Multi-Vector Advanced Escort Low Turn in Sector (http://sto-forum.perfectworld.com/showthread.php?t=266980)

Archived Post 04-18-2012 02:47 PM

Multi-Vector Advanced Escort Low Turn in Sector
 
Logged in today and while in sector space I noticed i went from turning on a time to turning Slower than a cruiser ( <5 degrees/sec) Didn't have this problem yesterday. Was wondering if anyone else was

Archived Post 04-18-2012 03:05 PM

Reading this post figured I had to check it out.
I thought is was a unique issue, but as it turns out I have the same issue now.
It takes 2/3 the with of a sector block for me tu turn my ship 180 degrees as oppsed to before when I could almost turn on a dime.

Oddly enough its only in sector space, and not when on missions or local space.

Archived Post 04-18-2012 03:12 PM

Quote:

Originally Posted by Bansheedragon
Reading this post figured I had to check it out.
I thought is was a unique issue, but as it turns out I have the same issue now.
It takes 2/3 the with of a sector block for me tu turn my ship 180 degrees as oppsed to before when I could almost turn on a dime.

Oddly enough its only in sector space, and not when on missions or local space.

its weird cause I was able to turn on a dime previously I wonder if the Dev's screwed with the rate or its just a bug. yeah same issue only in secotor space


All times are GMT -7. The time now is 09:14 PM.