Star Trek Online

Star Trek Online (
-   Builds, Powers, and Game Mechanics (
-   -   Trouble Training Dampening Field (

Archived Post 05-07-2012 02:00 AM

Trouble Training Dampening Field
Having trouble with training my Boffs in Dampening Field I, tried searching the forums for something related but didn't have any luck. Wondering if this is just ticket worthy or if it's a bigger bug (Or one with a known work around).

Sci Captain, with the ability to train Dampening field for Lt. Commander ground slot. Taught it to a ensign boff, then trained them up. However, at Lt. Commander rank, they have no "one point" allocated to it and was unable to skill them up with it, although they do for their Lt. Commander space ability. Promoted them up to commander, which then showed none of the (now three) remaining abilities having that first point. However, I could give skill points to the other two abilities at Cmdr rank and it would unlock it for the Lt. Commander Dampening Field power.

Problem is, after pressing accept, those skills all reset momentarily. Attempted zone changes and relogs, problem persisted.

Trained a different Lt. Commander ground power over it and it worked properly, was able to train all abilities. Tried to re-train in dampening field after. Pressing the accept button gives all the proper "Do you really want to train" dialogs, but there is no change; the training window does not close.

Is this known? Is it a bug with the ability? Did I accidentally break something? Are Sci just unable to properly train the power "Dampening Field I"? Any work arounds?

Archived Post 05-22-2012 11:17 AM

I experienced the same problem and on a search of the BOFF forums your post was the first I had found. I also tried train two science officers one as a Lt Cdr and the other who was promoted from lower ranks. Both resulted in the same situation you detailed. Maybe I'll check the bugs forum next.

Great. The ability is intended for a commander but the officer mistakenly trains it into the LCdr slot. Then because it the skill isn't supposed to be present until tier 4 and resides in the 3rd tier it won't let you train it. Looks like this has been a problem for a while so I don't see the point of adressing it.

All times are GMT -7. The time now is 01:28 AM.