Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Graphical and Sound Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=148)
-   -   Is it safe to update Catalyst yet? (http://sto-forum.perfectworld.com/showthread.php?t=304781)

tangolight 07-11-2012 03:39 AM

Is it safe to update Catalyst yet?
 
Quote:

Originally Posted by Archived Post (Post 4130721)
Screen renders as a blocky mess using AMD video cards.
THE WORKAROUND: Downgrade your AMD graphics driver to version 12.1.

THE FIX: AMD is working on it.

THE UGLY TECHNICAL DETAILS:
Version 12.2 of the AMD driver has something horribly wrong with it. AMD is (hopefully) working on a fix for this. It's not just affecting our games.

You may have to completely uninstall your AMD driver before installing the 12.1 version. It's been reported that the driver rollback feature didn't work for someone.

FORUM THREADS:
http://forums.startrekonline.com/sho...d.php?t=263130
http://forums.startrekonline.com/sho...d.php?t=263321
http://forums.startrekonline.com/sho...d.php?t=259428
http://forums.startrekonline.com/sho...d.php?t=260437
http://forums.startrekonline.com/sho...d.php?t=261411

The most recent version of ATI/AMD's Catalyst drivers are now 12.6. I recall hearing that the version prior to 12.6, (which was 12.4) still had the same issues, but I was wondering if anyone had tried the latest version yet and whether it still had the same issues that 12.2 - 12.4 had?

I'd have posted in one of the other threads, but they're all older than 30 days now.

thoroon 07-11-2012 03:48 AM

My GF plays with 12.6 pretty fine, she also had no problems with 12.4

jcsww 07-11-2012 08:24 AM

I am running the 12.7 beta and no issues at all.

tacofangs 07-11-2012 10:30 AM

Yup, you should be good now.

darkstarkirian 07-11-2012 11:07 AM

Quote:

Originally Posted by tangolight (Post 4697501)
The most recent version of ATI/AMD's Catalyst drivers are now 12.6. I recall hearing that the version prior to 12.6, (which was 12.4) still had the same issues, but I was wondering if anyone had tried the latest version yet and whether it still had the same issues that 12.2 - 12.4 had?

I'd have posted in one of the other threads, but they're all older than 30 days now.

I can't use the latest version. I get an Install message saying it isn't supported.
Guess my ATI Mobility Radeon HD 5145 has doomed me to gimpy land... :(
At least it was nice of the AMD page to tell me after the fact that Toshiba Notebooks are not compatible.

lordhavelock 07-11-2012 02:28 PM

This thread is relevant to my interests. Thanks for the info. I shall update my drivers accordingly. :)

jcsww 07-11-2012 05:15 PM

Quote:

Originally Posted by darkstarkirian (Post 4703621)
I can't use the latest version. I get an Install message saying it isn't supported.
Guess my ATI Mobility Radeon HD 5145 has doomed me to gimpy land... :(
At least it was nice of the AMD page to tell me after the fact that Toshiba Notebooks are not compatible.

There are sometimes ways around that. if you check the AMD Game forums, you might find more help there. My Acer Aspire 8935G has a similar issue due to using both integrated and descrete graphics. However, disabling the integrated and forcing the latest Mobility driver works for me when I need to update.

imarookie 07-12-2012 11:09 AM

I got no real driver problems with my Radeon 4890 but instead
had and sometimes have glitches where I cannot see my weapons fire and other effects like the vented plasma even when its only 3-4 ship lengths away.

If there is already a special thread for this kind of nuisance I didnt see it. :)

anyways, 8x AA combined with transparency AA seems to be working now.


All times are GMT -7. The time now is 01:54 PM.