Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   The Still Broken Diplomatic Immunity / Transwarp Thread (http://sto-forum.perfectworld.com/showthread.php?t=329341)

saturnprime 07-26-2012 05:54 PM

The Still Broken Diplomatic Immunity / Transwarp Thread: Fix in Second Post!
 
Since January and the creation of the DOFF system, I have not been able to transwarp to Starbase 39-Sierra and DS9 as part of the Diplomacy leveling Perks. In addition, I do not have the Grant Diplomatic Immunity ability and cannot enter the Klingon sector with my affected Fed character without someone else granting to them.

Yes, I've talked to Lt. Ferra and have I bugged it about once a month. Sometimes I get a form reply, sometimes not.

So SaturnPrime, What else is new??

I'm glad you asked. Since the Season 6 update, I ALSO cannot purchase Transwarp Coils from the the Dilithium store and the Fleet Starbase System does not appear in my Transwarp menu. When attempting a Transwarp Coil purchase, the game states I don't have enough refined dilithium when I have far more than the purchase price.

I would guess that Transwarps unlocked by my fleet will not show as well, but we have not gotten that far yet.

Long ignored bugs are piling up for me and locking me out of new features. I would bet that they are related. The game is rumored to add another sector at some point and it is frustrating having to wait for someone to give DI or make a trip that others don't have to.

CRYPTIC, you shouldn't have left this broken. Put someone on this.

If anyone else is still having this issue, please leave a post.

saturnprime 07-28-2012 08:59 PM

Fixed!!
 
I am so unbelievably happy to announce that I have discovered that you can fix the above issue by respecing your character/captain, making sure you use all your ability points in the process. My character was pre-respec 1000 skill points short of the maximum of 366,000. After doing the respec and allocating all skill points and accepting, the transwarps then showed in the menu and Diplomatic Immunity power appeared selectable from the powers tray.

My clue was the transwarp coils from the dilithium store being locked out for me. Those transwarps appear in the powers tray for activation, not the transwarp menu. For 7 months, I believed the issue existed in the DOFF system failing to report diplomacy commendation levels to the powers system. I now think that captains with "incomplete" respecs prevent the system from adding granted or earned powers like Diplo Immunity and Transwarps if all ability points are not used. There probably were a bunch of players like me that completed respecs without all ability points being used during the DOFF system introduction, since I believe that update forced a respec on players.

Level 50 characters are probably affected by this bug the most. Players that were/are in the process of leveling would have "fixed" the issue when they allocated skill points to unlock the next rank.

astraz1701 08-03-2012 08:37 AM

Thank you SO much!!! Respecing to use all points worked also for my girlfriend's main that had the same problem!!!

GREAT!!!! :D

kbflordkrueg 08-03-2012 09:04 AM

Since you discovered it wasn't a long Cryptic ignored bug, but rather player error, maybe you should modify your OP, eh?

forjoatinxan 08-06-2012 10:36 AM

Quote:

Originally Posted by kbflordkrueg (Post 5112771)
Since you discovered it wasn't a long Cryptic ignored bug, but rather player error, maybe you should modify your OP, eh?

How is it a player mistake? I have the same issue and have 500 points left over that cannot be spent. Why should I have to respect to enable an unrelated feature? There are no rank requirements for these skills beyond the initial LT 7 for the DOff system.

And there is still no log entry when you rank up diplomacy. Try it out. Type commendation in the mission log. You'll see rank up entries for every other discipline except diplomacy.

It's a bug and it's still broken.

-Forjo

saturnprime 08-16-2012 09:10 PM

Quote:

Originally Posted by kbflordkrueg (Post 5112771)
Since you discovered it wasn't a long Cryptic ignored bug, but rather player error, maybe you should modify your OP, eh?

Saw this post. :rolleyes: It's a bug, not player error. My skills and respec points were a valid setup before the DOFF system existed. It is absolutely possible to get into a position where you spend nearly all your points and not enough (just 500) to fill another skill bar. The game has accepted respecs like that and probably still does. I don't want to test it with my character after I fixed it.

If the game threw up a huge warning and said, "You HAVE to spend all your points or else things like Transwarp Coils, Diplomatic Transwarps, and Diplomatic Immunity will break.", this poster may have a point, but it doesn't and Cryptic didn't figure it out after months of posts since the DOFF system debuted in January. I figured it out (or at least I posted a solution).

I am very happy that this workaround solution has worked for other people.


All times are GMT -7. The time now is 02:16 PM.