Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Not getting credit for C-store purchases. (http://sto-forum.perfectworld.com/showthread.php?t=334511)

wilv 07-30-2012 10:34 AM

Not getting credit for C-store purchases.
 
I purchased the t4 & t5 versions of the Galaxy, Intrepid & Defiant class when they were first released. Today I tried to claim a t5 intrepid on a new character and it told me I needed to pay 2k Zen. Instantly I did a double take and thought this MUST be an UI glitch so I went online and checked the C-store page on the site and sure enough It was telling me that ships I had spent money on were no longer unlocked. I am being credited for the T4 versions of the ships but NOT the t5 even though I've purchased both.

Has anyone else experienced this? I didn't have this issue before season 6.

kobayashlmaru 07-30-2012 10:39 AM

In-game, are you looking at the Legacy tab or Ships tab?

thecosmic1 07-30-2012 10:40 AM

There seems to be a glitch with the T5 Defiant, Galaxy, and Intrepid. I've seen other posts on the forum from people who say they've purchased one of the T5 Refits and it's not showing they own them. The best you can do is file a ticket and keep on CS.

kamiyama317 07-30-2012 10:52 AM

They really need to set up a page where we can log in and see our C-Store purchase history.

wilv 07-30-2012 10:57 AM

Quote:

Originally Posted by kobayashlmaru (Post 5042141)
In-game, are you looking at the Legacy tab or Ships tab?

In-gmae I looked at both. I've never had to look at the legacy tab to claim one of these ships before but did it today thinking perhaps they were moved since they did so many changes. Unfortunately there is NOTHING there.

I've ALWAYS been able to simply go to my c-store tab, hit the claim button and select the ship. I did it just shortly before season 6 went live. I'm wondering if the glitch is because I've purchased both the t4 and t5 versions.

kobayashlmaru 07-30-2012 11:05 AM

Quote:

Originally Posted by kamiyama317 (Post 5042271)
They really need to set up a page where we can log in and see our C-Store purchase history.

I doubt this exists, which is why we don't see it. Besides, it won't help in this case. If the system says you didn't purchase it, it wouldn't appear on your purchase history anyway.

OP, do you have any characters who already have the T5 ship? Maybe use that as reasoning and submit a ticket to support and see what they say.

wilv 07-30-2012 11:10 AM

Quote:

Originally Posted by kobayashlmaru (Post 5042491)
I doubt this exists, which is why we don't see it. Besides, it won't help in this case. If the system says you didn't purchase it, it wouldn't appear on your purchase history anyway.

OP, do you have any characters who already have the T5 ship? Maybe use that as reasoning and submit a ticket to support and see what they say.

I submitted the ticket and yes I have several toons that have the ship. Unfortunately the ships are also available w/ a Vet token so I fear this will be a pain to prove that I bought the ship w/ c points and not a Vet token.

namod83 07-30-2012 11:14 AM

I've seen something similar, I purchased the cloaky defiant, and now it says I must rebuy it on my other 2 toons, even though I have it on my Tac Officer. *edit* Also I bought the dreadnaught awhile back on my Sci and it says I must rebuy on my Tac and Eng...

Also, on that Tac it says I need 4 fleet mods for the fleet version. Shouldn't it be just 1 since I own the cloaky defiant (tac escort retrofit)?

This needs to be addressed ASAP.

darkjeff 07-30-2012 12:12 PM

Quote:

Originally Posted by kobayashlmaru (Post 5042491)
I doubt this exists, which is why we don't see it.

I strongly believe it exists, especially since it's been mentioned in the context of people thinking they didn't receive their stipend, and a rep said that they checked the logs and it was paid out.

wilv 08-01-2012 02:04 PM

Well it's been 3 days since I reported this issue and I've yet to hear a word on the subject from Cryptic/PWE. :(


All times are GMT -7. The time now is 01:19 AM.