Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   The Academy (http://sto-forum.perfectworld.com/forumdisplay.php?f=127)
-   -   new (http://sto-forum.perfectworld.com/showthread.php?t=386431)

booboobottie 09-14-2012 02:03 AM

new
 
Sorry to bother everyone but I?m new to this and a bit naive when it comes to computers
when I try to start keeps coming up trying to update launcher have tried to for 2 days now but no success any help would be appreciated

thecosmic1 09-14-2012 06:39 AM

The first thing the game does is load and update the Launcher. After that it starts patching all new changes in the game - the game you downloaded originally isn't the final version, as the game keeps changing each week, so you need to download a patch almost as large as the original game.

If you're loading the Launcher and it doesn't fully load and connect to the internet then that could mean it's being blocked by your Firewall/Virus Protection - your security isn't allowing the Launcher to connect with Cryptic's servers to get the necessary updates to finish the process. You either need to turn off your Firewall/Virus Protection and try loading the Launcher again, or you need to create Exceptions within your Firewall/Virus Protection to allow the Launcher to connect to Cryptic's servers. I think I needed to make 5 or 6 Exceptions, and reload the Launcher a couple of times before my McAfee would allow the Launcher to work properly. You might be in the same boat with your Virus Protection.

chuckwolf 09-14-2012 06:28 PM

I don't think it's his system I abruptly lost connection to the STO server while playing earlier today and upon trying to log back in find out I can't connect to the update server either. I actually disabled windows firewall so that's not an issue.


All times are GMT -7. The time now is 12:54 AM.