Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   The Foundry for Star Trek Online - Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=212)
-   -   New Objects Disappearing over Old Objects (http://sto-forum.perfectworld.com/showthread.php?t=396081)

nikoagonistes 09-23-2012 02:39 PM

New Objects Disappearing over Old Objects
 
According to the normal way the Foundry map tool works, newer objects normally are "above" older ones, even if the older ones have an equal or greater "Y" value on the 2D map where the objects are manually placed.

However, while making a city - a city that already has a lot of objects - I've noticed that when I try to place a new object (whether it be a buidling, detail object, or even a complete mob), it now appears below all the already established objects - inlcuding platforms (that I plan to use for streets and such), and buildings. Which makes it very, very tough to look at how a new object (or series of new objects) relate to already established stuff without going to test mode, logging out, adjusting, going to test mode again, etc.)

I know this has happened intermittently before, but now it seems consistent. Has anyone else encountered this, and if so, is there any way to fix this?

castsbugc 09-24-2012 08:12 PM

I will 'tell' you that the object doesnt disappear. Its some kind of oddness with the database entry for the positioning of the object. It doesnt maintain its 'last in' and somehow falls down the list.

It gets odder, because of you delete this item later, even if it was 20 items back in placement, the next time after you deleted the 'fallen' one will also fall down the list. There have been times when I have had 20 odd discarded items sitting on the corner of a map because I didnt want to delete them until the end after I had placed everything I wanted where I wanted so I could see the positioning and not have to worry about it.


All times are GMT -7. The time now is 04:30 AM.