Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Phaser/Disrupter Lotus drains ALL weapon power (http://sto-forum.perfectworld.com/showthread.php?t=411761)

trek21 10-11-2012 02:26 AM

Phaser/Disrupter Lotus drains ALL weapon power
 
Test-driving these ships, the power states that it drains 75 weapon power upon completion.

However, both ships were using the attack preset, and were usually around 100 weapon power when firing weapons, with 85-ish being the lowest observed. The power drain from using the Lotus would be steep, but it shouldn't drain all power.

But instead, it drains ALL weapon power, whether you're at 80 or 125. And it keeps your weapons offline by staying at 0 for a few seconds.

Further testing has shown this is a consistent side-effect.

Anyone else seeing this?

mattjohnsonva 10-11-2012 02:37 AM

Confirmed, Lotus drains all weapon power completely, no further shots are available for a few seconds whilst it recharges, have your batteries at the ready!

reyan01 10-11-2012 03:07 AM

Possible that equipping an EPS Flow Regulator console would be of benefit? May be worth a try.

grouchyotaku 10-11-2012 08:11 AM

Quote:

Originally Posted by trek21 (Post 6040891)
However, both ships were using the attack preset, and were usually around 100 weapon power when firing weapons, with 85-ish being the lowest observed. The power drain from using the Lotus would be steep, but it shouldn't drain all power.

Are you using the Lotus by itself? Or in combination with other Weapons? (which would add their own power drain)

trek21 10-11-2012 03:14 PM

Quote:

Originally Posted by grouchyotaku (Post 6044241)
Are you using the Lotus by itself? Or in combination with other Weapons? (which would add their own power drain)

I've tested the Lotus quite a few times, both with other weapons firing, and as the first shot in battle (literally not touching the other weapons).

Every single time I've used it, the Lotus drained all weapon power, instead of it's described 75.
Quote:

Originally Posted by reyan01 (Post 6041121)
Possible that equipping an EPS Flow Regulator console would be of benefit? May be worth a try.

EPS Flow Regulator only boosts the recovery speed (which happens a few seconds after your weapon power drops to 0). With or without it, the Lotus drains all weapon power, regardless of modifiers.

bones1970 10-11-2012 03:41 PM

Used Nadion Inversion and eps before shooting it, did nothing, weapon power still went to 0

trek21 10-11-2012 06:08 PM

Quote:

Originally Posted by bones1970 (Post 6050771)
Used Nadion Inversion and eps before shooting it, did nothing, weapon power still went to 0

^ Which is definitely an issue. Not exactly game-breaking, but quite annoying

khayuung 10-11-2012 06:10 PM

Can we keep it that way? The Lotus needs a nerf for making my DNC jealous. :P

admiralthorr360 10-12-2012 12:03 AM

Confirmed, this bug is somewhat annoying. Also weapons batter doesn't quite help return power after instantly as it should.

jnohd 10-12-2012 12:25 PM

Confirmed here as well on KDF. Drains my 125+ to 0, turns the icon red and stays at zero for a bit before it begins regenerating. Using a battery right away wastes it, wait the few seconds for the icon to return to a normal color, then pop the batt and resume fire. (I found it useful to use it just before a torpedo spread.)

It also appears to lock you out of any other abilities until the animation starts?

1) Fix it?
2) Apply the -75 *before* the hard cap?


All times are GMT -7. The time now is 12:43 PM.