Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   C-Store, ZEN, and Promotions (http://sto-forum.perfectworld.com/forumdisplay.php?f=200)
-   -   Firework emote for Klingon character (http://sto-forum.perfectworld.com/showthread.php?t=412531)

scbypwr 10-11-2012 11:13 PM

Firework emote for Klingon character
 
Any idea where this is.

Could not find it in the shipyard or the barracks.

Help would be greatly appreciated.

odyssey47 10-12-2012 03:46 AM

The fireworks emote is a 300 day veteran reward that's for Fed and Klingons. So you need to sub for 300 days or get a lifetime sub and you'll get it right away.

dapperdrake 10-12-2012 04:18 AM

stowiki says "at the console (north of Commander Ragen) along the east wall of the Barracks". I searched again and again for my orion KDF. NOTHING! I'm lifetime and I got it for my main toon in fed side (in esd). Once again it's broken for klings. No doubt about!

defalus 10-12-2012 04:32 AM

I just made a new character to check this for myself, I was able to claim the fireworks device. I took a screenie with my map open to show where the console is so if it doesn't work for you it is most likely a bug.

Screenie

dapperdrake 10-12-2012 04:43 AM

Ok. Thank you very much. I checked it. I tried with my two kdf toons. It seems there is bug for my two kdf toons :(

scbypwr 10-12-2012 08:25 AM

Thank you very much for the screenie....I am also unable to claim the emote and I am a recent lifetime subscriber.

I was able to claim the fireworks emote for my fed toons...not for my klink.

darkthorne70 10-12-2012 10:01 AM

didnt work for me at first but was able to claim it last night...

dapperdrake 10-13-2012 10:26 AM

I tried to GM, but it seems they like to laugh at people. They ask me to send screenshot. And it's impossible.
They don't believe the console in north of Commander Ragen is off for me.
Look

fonz71 10-15-2012 10:32 AM

i too am having difficulty claiming my fireworks... all three kdf toon can not claim,,, but both fed toons have.... ii have no suggestions other than filling out a ticket... hopefully somebody responds.. lol

maddog0000doom 10-15-2012 03:07 PM

have u tryed changing instance sometimes that works

ps try logging out and back in


All times are GMT -7. The time now is 09:49 AM.