Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Tribble - Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=229)
-   -   Defera invasion not rewarding Omega Marks (http://sto-forum.perfectworld.com/showthread.php?t=423341)

valiant797 10-23-2012 10:31 AM

Defera invasion not rewarding Omega Marks
 
Current list of working Defera missions for Omega Marks

City:
[Hard] City: Knowledge is Key 10 Omega/ 10 Fleet / Invasion item confirmed
[Medium] City: Locked In (no Omega)
[Medium] City: Peer Pressure 7 Omega/ 5 Fleet confirmed
[Easy] City: Automated Aggression (no Omega)
[Easy] City: Modus Operandi (no Omega)

Power Plant:
[Hard] Power Plant: Getting to the Bottom of Things 10 Omega/ 10 Fleet / Invasion item confirmed
[Medium] Power Plant: Closed Off 7 Omega/ 5 Fleet
[Medium] Power Plant: Power Play 7 Omega/ 5 Fleet
[Easy] Power Plant: Cooler Heads 5 Omega/ 3 Fleet confirmed
[Easy] Power Plant: Power Hogs 5 Omega/ 3 Fleet confirmed but bugged (upon 1st turn in no longer gives Omega Marks)

Temple:
[Hard] Temple: Uninvited Guests 10 Omega/ 10 Fleet / Invasion item confirmed
[Medium] Temple: Conflicted Orders (no Omega)
[Medium] Temple: What's Mine is Mine (no Omega)
[Easy] Temple: Higher Ground (no Omega - may have similar bug to Power Hogs)
[Easy] Temple: Preservation of Knowledge (no Omega)

Probe:
[Hard] Probe: Counter Offensive 10 Omega/ 10 Fleet / Invasion item confirmed

(note: a lot of the zone-wide missions do not grant Omega Marks, they give crafting materials)

Side note, would be nice if Cmdr Roxy listed all the possible places in game to earn Omega Marks. Might help non-forum junkies



Thanks to diogene0 and DoctorDementile to help me run some missions

doctordementile 10-23-2012 10:46 AM

Also, this:

http://sto-forum.perfectworld.com/sh...d.php?t=383291

usscapital 10-23-2012 04:08 PM

added omega marks to defera ? , not working for me , just done the mission where you have to remod the turrets and it did not reward them . just got the fleetmarks and ec's yet it says i should have got 5 omega marks , neither is the mission where you have to stop the borg from venting plasma from the cooler heads or what ever they are called

edit: only one's i have found that work are the easy missions from jula or what ever here name is lol

doctordementile 10-23-2012 07:17 PM

There's a pattern for which ones give Omega marks and which ones don't. I'm willing to believe this is working as intended.

usscapital 10-23-2012 07:56 PM

Quote:

Originally Posted by doctordementile (Post 6232901)
I'm willing to believe this is working as intended.

lolz :D:D:D

usscapital 10-24-2012 04:12 AM

another bug ? :

while the fleet event is on you do not get omega marks where i did yesterday when it was not the fleet event (same mission: where you have to deploy the 12 antiproton turrets)

are the devs reading these at all ?

nicha0 10-24-2012 07:01 AM

I would love to see my bug thread addressed, really that whole zone feels like a giant, incomplete buggy as hell joke. They never even finished the comm tower section, just moved onto the next project.

usscapital 10-24-2012 01:09 PM

Quote:

Originally Posted by nicha0 (Post 6237781)
I would love to see my bug thread addressed, really that whole zone feels like a giant, incomplete buggy as hell joke. They never even finished the comm tower section, just moved onto the next project.

so are we all wasting our time here on tribble ? , why are the devs ignoring these bug reports etc ? . they claim to listen to the player base but it seems this is untrue tbh

zer0niusrex 10-24-2012 06:42 PM

Quote:

Originally Posted by doctordementile (Post 6232901)
There's a pattern for which ones give Omega marks and which ones don't. I'm willing to believe this is working as intended.

The patch notes have a known issue that the rewards for that are a work in progress.

valiant797 10-25-2012 05:33 AM

Thanks for the reply Zero (may I call you Zero)

When I posted this thread it was before the latest tribble patch which added them to most of the missions (it ended up actually being minutes before the shard update). I was able to earn some Omega Marks on Defera after the shard came back up.

What may be more useful now is for anyone to report when the mission displays that it should pay out Omega Marks but it doesn't upon turn-in, bearing in mind as Zero said, there are some of the missions that aren't hooked up yet (it appears to be a couple of the easy ones that aren't hooked up yet), so check the reward list before reporting.


All times are GMT -7. The time now is 02:46 AM.