Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   C-Store, ZEN, and Promotions (http://sto-forum.perfectworld.com/forumdisplay.php?f=200)
-   -   Can't buy Zen (http://sto-forum.perfectworld.com/showthread.php?t=428231)

devencombs 10-29-2012 01:02 AM

Can't buy Zen
 
I'm stationed in South Korea by the US military. In order for me to access the STO and PWE websites, I have to make use of a VPN program. The VPN works fine except when it comes to buying Zen. The PWE site demands that my address be from the US, so I have to connect my VPN. But when I try to checkout, the company they process payments through will not allow the use of the VPN. Rock and a hard place. What can I possibly do?

stark2k 10-29-2012 01:12 AM

Farm, Farm, Farm, Farm, Farmville.

Otherwise you're S.O.L.

meehee 10-29-2012 03:12 AM

you could try downloading steam and installing STO through steam then you should be able to use the steam wallet to purchase ZEN. From what i can tell steams services should be available in south korea.

you can even make a desktop shortcut to STO to start the game normally and only ever use steam for the zen purchases. A far simpler method than trying to navigate through the PWE website ;)

mailman650 10-29-2012 07:17 AM

Contact their billing department, I had an address situation as well not too long ago myself, PW fixed the issue in three-four days. Now I can make purchases hassel free.

devencombs 10-29-2012 09:04 AM

That's another problem. I have tried to contact them, but every time I click on the link to do so, the browser can't load the page. Something about too many redirects.

oldkirkfan 10-29-2012 02:26 PM

Do you have relatives in the states... or the UK?

You can have them buy a PWE card and put Zen on your account, then simply pay them back. Set up a direct deposit to a bank back home to a trusted family member. Deposits can be as little as $20usd to a Walmart pre-paid card....

devencombs 10-29-2012 03:56 PM

The issue has just been resolved. Before, I was trying to pay for the Zen with my debit card. Just now though, I tried using my PayPal account and it worked. I wish I had known that before, but I guess it's FYI for anyone else who might have this problem.


All times are GMT -7. The time now is 10:36 PM.