Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   launcher wont load (http://sto-forum.perfectworld.com/showthread.php?t=439901)

cowkiller75 11-09-2012 04:11 AM

launcher wont load
 
the launcher is not loading. you put your password in then its says loading launcher...and nothing. so i guess sto is broken......anyone else having this problem

suaveks 11-09-2012 04:18 AM

Yup. Just wanted to log in and it won't move past Loading launcher info.

captainrevo1 11-09-2012 04:18 AM

This has been happening for years.

every single day, around now, the launcher hangs for about 15-20 minutes and you cant enter.

give it 10 minutes and it will be fine.

suaveks 11-09-2012 05:00 AM

Well, that's the first time I see this, and I've been playing (with breaks) since beta, often at about this hour. ;) Thanks for the info anyway - it works now.

lyanaar 11-09-2012 08:16 AM

Same problem here. Played yesterday...but today the launcher hangs. Same with Champs Online. Other games/inet work fine.
Maybe the STO/Champs patchserver is the same?

neohunter200 11-09-2012 11:02 AM

Mine's worse.

The launcher window appears but displays the sentence "Loading. Please wait..."

After a couple of minutes, I will get an error page that says "This program cannot display the webpage". Been trying almost the whole night but to no avail.


All times are GMT -7. The time now is 07:48 PM.