Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   STO Gateway: Bugs and Technical Issue (http://sto-forum.perfectworld.com/showthread.php?t=442711)

pwebranflakes 11-12-2012 05:01 PM

STO Gateway: Bugs and Technical Issue
 
This is the Star Trek Online Gateway bugs and technical issues thread! Please post any bugs, error messages, or compatibility issues here!


What is the Star Trek Online Gateway?

Star Trek Online Gateway is a web application which lets you look at your captains, ships, bridge officers, and other data from STO. Eventually, you will be able to interact with Star Trek Online through Gateway without logging in to the full 3D client.

The purpose of Gateway is to let players into Star Trek Online without needing to start up the full client.

Visit http://gateway.startrekonline.com to access the STO Gateway.

Feedback

Star Trek Online Gateway is in early Beta, and we look forward to hearing what you think about it. Let us know what you're thinking by posting to this forum thread.

If you have technical issues or experience any bugs such as problems using Gateway with your web browser or device, please let us know by commenting below in this forum thread. Please let us know what operating system and browser (including version numbers) you are using. If you are using a mobile device, let us know which one.

Also, take a glance at the Known Issues below for a list of things we already know about.

Browser Requirements

  • Gateway is tailored to work on desktop, tablet, and mobile devices supporting HTML5.
  • Gateway has been verified to operate on recent versions of Chrome, Opera, Firefox, Safari, and Internet Explorer. It may work on earlier versions of these browsers. It does not work on Internet Explorer 8 or earlier.
  • Gateway requires the use of cookies.
  • Gateway requires the use of Javascript.


Login Issues

You must log in to a Perfect World account to use Gateway. If you don't have one, you will have to create one first. If you have a Cryptic account, but not a Perfect World account, you will need to create a Perfect World account and link it to your Cryptic account before using Gateway.

Click here to create a new account or link an existing account.

Click here for more information on account linking.

Cookie Usage

  • A cookie is used to keep track of your session while you using Gateway. This is a "session cookie" and is not kept after you leave the page.
  • A second, persistent cookie is also used by Account Guard to determine if the particular browser install is authorized for use with your account. This cookie contains no account information.


Known Issues

  • Gateway does not work on Internet Explorer 8 or earlier.
  • Character changes that occur in the client are not immediately updated on the web. You must log out and back in to see the changes.
  • Pictures of bridge officers do not show the officer in their chosen stance.
  • Pictures of ships do not show additions or changes that come from equipment (e.g. Borg equipment, etc.)
  • Though Gateway uses the language preferred by your browser, there is some text that is not yet translated. Gateway supports the same languages Star Trek Online does: English, German, and French.
  • Some players may see their shuttle instead of their ship -- a fix is in the pipeline that will have the Gateway always show your ship.

keepcalm 12-10-2012 01:19 PM

Well, first bug, I guess. Can't use the gateway. I enter the username and password, get in to the one time code. I copy that over from my email and it immediately disconnects claiming to be down for maintenance. I try again, get prompted to enter the one time code, get disconnected. Recent version of Firefox, cookies and javascript are both enabled, just ... can't use this. Tested on two machines, same results.

akpa 12-10-2012 01:39 PM

a small one
 
i think i find a bug too:
here is a picture of it
my ship's hull is not 10000. the standard for Mirror Universe Reconnaissance Science Vessel is 28500.
the crew is not 449 but 500.

phaserrifle 12-10-2012 01:39 PM

I think there's something wrong with the traits bar, as nothing comes up for either of my characters.

othet 12-10-2012 03:32 PM

Ooooo! I don't like this one bit! [Security Breach]
 
Ooooo! I don't like this one bit! Sending user Name and Password over a non-secure site! What happened Cryptic you didn't make this mistake when it was on Tribble?:eek:

szioul 12-10-2012 04:53 PM

Won't show my actual ship. Keeps thinking my shuttle is my primary ship. Wasn't able to get it to show anything else, but small craft after shuffling them around in-game.

Edit: Oh, nevermind. Noticed it's a known bug, with a fix incoming. Can't delete post though.

ocholivis 12-10-2012 04:56 PM

Can't Use From Windows Phone 7
 
Just FYI.

Trying to use it from my Nokia Lumia 900 (Windows Phone 7.5, mobile Internet Explorer), and after entering username/password it's just stuck on "Accessing Player Files. Please wait..."

This may go along with the the whole "Not working for Internet Explorer 8 or earlier", but it is different than those. I'm using the mobile version of Internet Explorer 9.

eradicator84 12-10-2012 05:35 PM

Apart for being disconnected constantly due to "being down for maintenance". After I logged in and selected my KDF toon things looked good.

Interface changed to red per KDF theme. However after being disconnected and returned to the login screen, the login screen bars at top and bottom of screen, and the border around the login box remain red whilst the rest of the login screen is themed for feds with blue.

Only a minor thing but it either needs to go back to completely fed themed or do a whole KDF theme (change background to something KDF plus login button and beta word colours).

The mish mash of both looks wrong
http://i48.photobucket.com/albums/f2...tathemebug.jpg

Using Firefox 17.0.1 on Win7.

eradicator84 12-10-2012 05:41 PM

Also, SSL needs to be implemented on the login screen. Don't like sending my game login details unencrypted over the net considering how much $$ I've put into this game.

dracos84 12-10-2012 08:35 PM

Haveing a problem loging in, just keeps saying accessing secure personnel files please wait. Dont know what elsa I can really do. Any ideas anyone?


All times are GMT -7. The time now is 03:20 PM.