Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   The Foundry for Star Trek Online - Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=212)
-   -   Dissapearing NPC Groups (http://sto-forum.perfectworld.com/showthread.php?t=475631)

thegreendragoon1 12-06-2012 09:08 AM

Dissapearing NPC Groups
 
I've noticed a bug that while in the Foundry preview, NPC groups seem to on occasion vanish half way through a fight. I haven't seen any evidence yet that this continues after publish, but even for testing purposes, this can be very annoying as it will break any attached objective or trigger.

drogyn1701 12-06-2012 09:58 AM

Are these mobs that you have patrolling? Cause I had that bug on tribble and it was with mobs I had set to patrol.

daiouvegeta2 12-06-2012 11:36 AM

I saw this in my mission yesterday during previewing. Both on ground and in space. Have two large groups in space and they would start vanishing while fighting one another, then reappear half a map away and start fighting again.

Ground is different, they'll just fall through the floor, regardless of elevation settings.

The falling through the floor ones were set on patrol, but not all of them were and it still happened.

Space has none set for patrol.

nagorak 12-06-2012 11:56 AM

I noticed that my NPCs were falling through the floor when in combat also and they were not set to patrol. It happened with every single NPC group on the Generic Starship Bridge, including my Boffs. I don't know if it happens on other maps because I haven't really checked.

Are the problems fixed after publish, because if not we have a big problem?

nagorak 12-06-2012 03:45 PM

I'm experiencing the problem in space as well. It seems to happen especially with the Hirogen Battleship when it uses Jam Targeting Sensors. It jumps 30 km away. But it happens with other ships, too.

The Hirogen Battleship also seems to wink out of existence sometimes if it can't immediately engage you. Something really screwy is going on.

And, even if it works after publishing, the current mess makes it so testing is almost impossible.

kirksplat 12-08-2012 05:09 PM

Quote:

Originally Posted by nagorak (Post 6964361)
I noticed that my NPCs were falling through the floor when in combat also and they were not set to patrol. It happened with every single NPC group on the Generic Starship Bridge, including my Boffs. I don't know if it happens on other maps because I haven't really checked.

Are the problems fixed after publish, because if not we have a big problem?

I just tested this on Generic Bridge 01. I had two mobs (Borg Lt 03 and Fed Lt 03) engaged in combat. Nobody fell through the floor. Was this the same bridge that you used?

markhawkman 12-08-2012 05:47 PM

I've been seeing a strange bug that causes both NPCs and Boffs to spontaneously relocate to a predefined location. The catch? It's not the default spawn point.... It might be the 0/0/0 point though. I'm not quite sure. Zelatta Space#2 after the battle starts some of the ships suddenly relocate to a spot in the dead center of the map.... and inside a planet... On outdoor ground maps, such as Zelatta surface, the point they move to is off the edge of the map and under the ground.... needless to say they don't come back. In the case of Boffs it seems to be triggered by them bumping into something. In any situation where they would stop moving they warp to the zero point.

this sounds like it might be related to your issue. But I've noticed that the issue disappears when you publish the map.

nagorak 12-08-2012 05:57 PM

Quote:

Originally Posted by nagorak (Post 6968301)
I'm experiencing the problem in space as well. It seems to happen especially with the Hirogen Battleship when it uses Jam Targeting Sensors. It jumps 30 km away. But it happens with other ships, too.

The Hirogen Battleship also seems to wink out of existence sometimes if it can't immediately engage you. Something really screwy is going on.

And, even if it works after publishing, the current mess makes it so testing is almost impossible.

It turns out the Hirogen Battleship winking out was because it was embedded in an invisible wall. Apparently NPCs despawn if they're stuck now. Increasing the size of the invisible wall cage fixed that problem.

However all other space NPCs warp far away. I think they're jumping to the middle of the map. It makes testing difficulty absolutely impossible in preview. Pathing works after publish, but it's going to be a major pain if we can't test combat balance until after publish.

nagorak 12-08-2012 06:06 PM

Quote:

Originally Posted by kirksplat (Post 6995601)
I just tested this on Generic Bridge 01. I had two mobs (Borg Lt 03 and Fed Lt 03) engaged in combat. Nobody fell through the floor. Was this the same bridge that you used?

Yeah it's Generic Bridge 01. They're falling through in preview. I haven't tested if it works after publish, but I expect that it does. Of course, reviewing is off, but no one as mailed me that they had a problem so far. I'll check to make sure it's all good in a few minutes.

kirksplat 12-08-2012 06:15 PM

Quote:

Originally Posted by nagorak (Post 6996021)
Yeah it's Generic Bridge 01. They're falling through in preview. I haven't tested if it works after publish, but I expect that it does. Of course, reviewing is off, but no one as mailed me that they had a problem so far. I'll check to make sure it's all good in a few minutes.


I was also testing in preview. Can you see if you can recreate it and then tell me the exact mobs that you're using?


All times are GMT -7. The time now is 02:07 AM.