Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Star Trek Online General Discussion (http://sto-forum.perfectworld.com/forumdisplay.php?f=128)
-   -   Excelscior Bug? or Easter Egg? (http://sto-forum.perfectworld.com/showthread.php?t=489661)

snipe048 12-18-2012 10:46 PM

Excelscior Bug? or Easter Egg?
 
I just tried to Transwarp from the Sol system to Eta Eridani using my Advanced Heavy Cruiser Retrofit and once the countdown hit 1 the nacelles started sparking with energy discharges and the ship made a sound similar to the original Excelsior in Star Trek 3 and my transwarp failed. I still got a cooldown but no transwarp jump.

Has this ever happened to anyone else?

hereticknight085 12-18-2012 10:51 PM

Re-read the description on your Excelsior. More specifically the part involving it's transwarp drive. You will have your answer there.

snipe048 12-18-2012 10:58 PM

Doesn't say anything about it having a chance to not work.

wunjee 12-18-2012 11:07 PM

On occasion, the engine will fail to make the jump. This was by design to mimic the events from Star Trek III: the Search for Spock when the transwarp drive on the USS Excelsior was disabled.

snipe048 12-18-2012 11:17 PM

Oh the wiki description, lol that's a nice touch, thanks for the help. :D

f2pdrakron 12-18-2012 11:22 PM

IT rarely happens, I think only happened to me once.

foundrelic 12-18-2012 11:59 PM

It says it on the store ship description too, including the quote from Scotty "The more they overthink the plumbing, the easier it is to clog the pipes."

diotw 12-19-2012 12:34 AM

I believe it's a 1% chance of failure. I've been flying the Excelsior for months, and I've had one failed transwarp jump the entire time. It's funny when it happens though, apart from having to now fly all the way across the galaxy. XD

defalus 12-19-2012 12:52 AM

In 2 years of owning an Excelsior it has happened to me once, I don't mind it failing now that we can jump to missions though.

The tuffli on the other hand seems to fail for me at least once a day when I use it, maybe all those jumps I make every 4 minutes:D

nyxadrill 12-19-2012 01:19 AM

Quote:

Originally Posted by defalus (Post 7150551)
The tuffli on the other hand seems to fail for me at least once a day when I use it, maybe all those jumps I make every 4 minutes:D

Same here, must be those darn Ferengi supplied warp coils again :D


All times are GMT -7. The time now is 07:48 PM.