Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   Sto on ubuntu ? I need help (http://sto-forum.perfectworld.com/showthread.php?t=494791)

sycrus 12-23-2012 12:37 PM

Sto on ubuntu ? I need help
 
I would relly want that sto operates on my ubuntu os
I tried so things with wine and windtricks but i cant seem to win against ubuntu
Im running ubuntu 12.10
Please give me a turotial to get sto on linux

This are things i installed with wine tricks:
D3dx9
Ie7 (ie8 didn't worked at all)
Vrun 2008 and i tried 2010
Flash player
And the corefronts

anazonda 12-23-2012 12:41 PM

If memory serves, the issue is in the .net part of the launcher.

Try launching the client, rather than the launcher.

sycrus 12-23-2012 12:53 PM

How do i start the client

And i dont now how but i did start the launcher and start the client
It crashd while loading and i didnt came so far again

And can i use the client when the game isn't patched

anazonda 12-23-2012 01:09 PM

Quote:

Originally Posted by sycrus (Post 7211691)
How do i start the client

And i dont now how but i did start the launcher and start the client
It crashd while loading and i didnt came so far again

And can i use the client when the game isn't patched

Im just bugtracing right now... I dont use Linux myself, but I have a fair deal of expirience with it.

If we can launch the game without the launcher, we know where to look... then we know where to start.

You need to find the game exe file in your mounts....

Not sure what it would be on linux, but on a Win, it should be "%program files%\Cryptic Studios\Star Trek Online\Live\GameClient.exe" i belive...

You probably have it in your /usr or /bin (or /etc?)

sycrus 12-23-2012 01:18 PM

Quote:

Originally Posted by anazonda (Post 7211821)
Im just bugtracing right now... I dont use Linux myself, but I have a fair deal of expirience with it.

If we can launch the game without the launcher, we know where to look... then we know where to start.

You need to find the game exe file in your mounts....

Not sure what it would be on linux, but on a Win, it should be "%program files%\Cryptic Studios\Star Trek Online\Live\GameClient.exe" i belive...

You probably have it in your /usr or /bin (or /etc?)

Doesn't the games exe just starts the launcher ?
But i also got a friend with a windows pc i can at least test it with the client

anazonda 12-23-2012 01:51 PM

Quote:

Originally Posted by sycrus (Post 7211861)
Doesn't the games exe just starts the launcher ?
But i also got a friend with a windows pc i can at least test it with the client

No... the launcher and the client are seperate enteties... The launcher simply provides patch access/evaluation as well as directed login.

The game client is usually launched through the launcher, but it is not required, if your client is up to date.

But... come to think of it, The launcher IS powered by IE... You might want to investigate if you can sucessfully install IE9 or later?

I will be offline for the next 8'ish hours... sleep is a b*tch, but nessacary.

Try my suggestions, and hope someone else can help you... If not, I will look into this thread tomorrow again...

anazonda 12-23-2012 10:28 PM

was skimming through the old forums, and found this:

http://sto-forum.perfectworld.com/sh...buntu+anazonda

Post #2 is mine... Seems it solved the issue back then.

sycrus 12-24-2012 12:16 AM

Ok had it alsmost functional i was able to get on the screen with the text cryptic
But it crashed on the next screen : the logo it didnt relly crashed but it just didnt get farder
I dont now how but i cant start the client not in the launcher and not by the gameclient.exe

anazonda 12-24-2012 12:39 AM

Ok, so that issue is removed from the checklist...

There is a file... MS*somethingsomething*.dll that the launcher initiates... It's apprearently not nessacary on the windows, but it might just be in Ubuntu...

Ill see what I can figure out

sycrus 12-24-2012 12:57 AM

Quote:

Originally Posted by anazonda (Post 7217941)
Ok, so that issue is removed from the checklist...

There is a file... MS*somethingsomething*.dll that the launcher initiates... It's apprearently not nessacary on the windows, but it might just be in Ubuntu...

Ill see what I can figure out

How do you get it
But the launcher works or is it for the client


All times are GMT -7. The time now is 05:04 PM.