Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Adapted Maco Engine (http://sto-forum.perfectworld.com/showthread.php?t=507971)

prestonpool 01-07-2013 11:37 AM

Adapted Maco Engine
 
the stats say that you get 3.8 to weapons, 3.8 shields, and 3.8 to Aux. but what i am actually getting is 0 to weapons, 1 to shields and 2 to Aux anyone else having this problem?

tenkari 01-07-2013 11:54 AM

what are your power levels? it works a lot like the old efficient impulse engines i believe meaning the actual boost varies on your power levels.

gbehlpnu2012 01-07-2013 12:03 PM

right now the engine gives bonus when your power level are low..upto 3.5....but like most equipment you get...the info is either incorrect when you view it and changes when you equip it....and will change again when you increase your speed.....its all a giant hot mess and probably the most hated aspect of sto programming.

prestonpool 01-07-2013 12:17 PM

3 fracking days wasted for crap another FAIL STO fix the stats in the omega rep system if i would have known this i wouldn't have even bothered to get it

quammen 01-07-2013 02:01 PM

Ingame stats for space are correctly pictured only in solar systems. If you had looked there at the item info before purchasing the engine, the problem could have been avoided.

prestonpool 01-07-2013 02:24 PM

I am sick and tired of people trying to put blame on players for cryptic/PW mess ups. if you bought a burger at mcdonalds and they gave you a chicken sandwich wouldn't you complain? yes you would so get off your high horse. STO fix your messes or else people will get tired of it and leave and find other more stable games to play. i like STO but if everything keeps getting messed up then what is the use. I play for entertainment, but if i run into nothing but missinformation and bugs then i will have no choice but to find a new game as this wont be a fun game anymore

mariothebros 01-07-2013 10:36 PM

A little addition
 
I'd like to add a bug related to Adapted Maco Mk XII Engine. I've acquired the engine for few days, but I kept it in my inventory. I notice from the preview in the reputation system that it carries additional powers except Weapon Power 0. It's rather peculiar because if it's not meant to give additional weapon power, why would bother stating 0 Weapon Power. Anyhow, this morning while in sector space, I saw that, in my inventory, Engine status had some numerical value (+3.5 or something) for Weapon Power, so it was something cool to have. Once I got my Adapted Maco Mk XII Shield, I put both engine and shield onto my ship. Lo and behold, when I placed my cursor over the Adapted Maco Mk XII Engine, the description stated 0 Weapon Power. :confused:

I hope this confusion can be straightened out soon. Regardless of this and other bugs, I'd say STO has been working hard to keep STO more fun to play. I sympathize with the dev for so much bug reports (because they are real) but sometimes less applause given for their achievements. :)

smartyn 01-08-2013 05:13 AM

If I had it to do again, I wouldn't bother with the Adapted Engines. By reading the stats they sound like a nice piece of equipment but the reality is they are bugged. The borg engines have a +5 to engine power and it doesn't change so why do the adapted engines change? It's probably a bug in the coding which will end up getting fixed but I think i'm gonna stick with the MACO or Borg engines either way. Having the adapted set doesn't make that big of a difference and the adapted engines can't break warp 10.

stirling191 01-08-2013 05:23 AM

It's a combination of two things:

STOs inability to tell the difference between ground and space stats

and

Efficiency.

When you're on the ground, the game thinks you have zero power to all subsystems (which you technically do because you're not actually in your ship). It bases any efficiency calculation (such as the Adapted Maco engine power boosts) off of those zeroes, and lo and behold you get big numbers. It's a similar idiosyncrasy to how you'll see miniscule hull and shield heal amounts if you look at space abilities while groundside.

synkr0nized 01-08-2013 05:24 AM

edit: didn't see that you had posted, stirling, while I was writing mine. I think we've more or less covered the same thing, but I'll leave this post as is anyway.


It sounds like you folks aren't familiar with "efficient" on engines overall, or at least the Honor Guard engines. It's not a bug in any coding, it's how engines with efficiencies have functioned for quite a long time.

Often you will have "Efficient at high" or "Efficient at low" power engines. This means that the higher or lower your power settings are will affect the bonuses. In this case, the engine is efficient at low power settings. This means that the higher your weapons, shield, and aux power settings are the lower the bonus; if they are high enough, you get no bonus.

Your power settings for your ship are obviously not present when you are on the ground. They are also not present when traveling in sector space. As a result, looking at an engine like this in either of these situations will only show you the max bonus you can receive for these powers. Only when the settings are active, such as a solar system or mission or combat area, will you see the actual bonus applied relative to your powers. And you'll also be able to see how it changes when you cycle through different power level settings (you do have more than one set up, right?).


While you might have a case that it's not a straightforward visual / interface choice, it's certainly not a bug. The KHG engines are perfectly fine, so don't sit on your thumbs thinking the adapted M.A.C.O. needs to be "fixed".


All times are GMT -7. The time now is 03:22 PM.