Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   Launcher Suddenly Not Working? (http://sto-forum.perfectworld.com/showthread.php?t=516291)

thlaylierah 01-16-2013 02:39 PM

Launcher Suddenly Not Working?
 
Even with their recommended link:

http://sto-forum.perfectworld.com/sh...21#post7508621

Standard support link error:

"Firefox has detected that the server is redirecting the request for this address in a way that will never complete."

captainrevo1 01-16-2013 02:41 PM

Works ok for me.

thlaylierah 01-16-2013 02:42 PM

Then you are lucky

captainrevo1 01-16-2013 02:44 PM

also in response to the link to the other thread, your gold priority login only comes into effect when the servers are jammed packed and there is a login queue. 99.9% of the time that is not an issue.

this has nothing to do with gold, silver or whatever. there is probably some technical error somewhere along the chain.

thlaylierah 01-16-2013 03:20 PM

Funny the SWTOR Launcher works!?

So I just got off the phone with my ISP.

She told me my relatively (2-3 weeks) new modem is off spec on one area and that might be causing the error?

I can easily play SWTOR, which I will be doing and not spending any money on STO or Champions this week.

So basically Cryptic's systems are just too picky or you have some other nefarious junk running that needs something other games don't?

Pretty suspicious.


All times are GMT -7. The time now is 09:05 AM.