Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Gameplay Bug Reports (http://sto-forum.perfectworld.com/forumdisplay.php?f=69)
-   -   Crew loss from torpedoes occurs on launch, not impact (http://sto-forum.perfectworld.com/showthread.php?t=541441)

xionstryke 02-05-2013 05:16 PM

Crew loss from torpedoes occurs on launch, not impact
 
It seems that crew loss proc from torpedoes is bugged.

1st, the crew loss to the target occurs instantaneously upon firing. The loss occurs as swift from 2.0km as it does from 9.9km.

2nd, preventing torpedo impact in no way negates this crew loss. A High-Yield Plasma safety destroyed by tractor repulsors does not prevent or refund this crew loss.

megacharge07 02-05-2013 08:05 PM

Interesting. I never noticed this before, this might explain why the borg super invisible torp 1 shot kills players the way it does, their crew may be too low and they just spontaneously explode as soon as the borg torp is fired.

x1ann0x 02-06-2013 05:55 AM

Also, crew loss is by no means what is written in the caption on the torpedo. I'm losing 200 crew on a 3000 crew atrox the moment someone fires a torpedo at me, no matter if it hits or not. That isn't the lesser of 20 or 20%.

oneandonlyrecce 02-06-2013 06:17 AM

Interesting.

It seems to confirm my suspicion that the "hit/miss" is calculated at the point of firing rather than when the "blow" is about to land. And so explaining why you still get hit by torps when you're moved out of range of the attacker. And why you can't escape torp spreads with sub-space jump.

megacharge07 02-06-2013 09:39 AM

Needless to say, this is really screwed up, and it's one of the most important things that needs to be fixed in the game right now.

wilbor2 02-06-2013 10:12 AM

yer ive noticed this its a cryptic special :P


All times are GMT -7. The time now is 10:31 PM.