Star Trek Online

Star Trek Online (http://sto-forum.perfectworld.com/index.php)
-   Windows and General: PC, Network, and Other Technical Issues (http://sto-forum.perfectworld.com/forumdisplay.php?f=401)
-   -   Min/Recommended system - what settings to use? (http://sto-forum.perfectworld.com/showthread.php?t=56176)

Archived Post 01-12-2010 01:03 AM

Min/Recommended system - what settings to use?
 
STO is the first MMO that makes my system "feel old". For the first time my CPU is the minimum recommended (AMD Athlon X2 64 3800+ with little to no upgrade options on the darn board :mad: ).
My GPU is the recommended one: geForce 8800GT (512MB - XFX Underdog factory OC).
The system has Win 7 64-bit and 2Gb memory (can't intall more on the darn board :mad: )

I know, I need to buy a new computer someday, because this one is getting old, but right now I don't see the real use for a new system...

So I was wondering what videosettings I should use to play STO smoothly...
I normally set my resolution to 1600x1200 @ 75hz (yes, I have an old CRT, but it's a very good one). Playing LotRo I've set all to the max, except for far distance which I've set to the 2nd best. This works very well for LotRo and I get an avarage FPS of 35-50 (depending on where I am). Only in Bree the FPS drops to around 22...

For now I've set STO to the max as well, and the intro screen showed a nice 35-40 FPS, but I wonder what will happen when I start to play STO. How much will the FPS drop, will it become real choppy and should I lower the settings dramatically? Also, should I lower the resolution as well (1280x1024 probably)?

Any input (other than buy a new PC) is welcome ;)


All times are GMT -7. The time now is 12:25 PM.